summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tzlocal/tzlocal-5.2.ebuild')
-rw-r--r--dev-python/tzlocal/tzlocal-5.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/tzlocal/tzlocal-5.2.ebuild b/dev-python/tzlocal/tzlocal-5.2.ebuild
new file mode 100644
index 000000000000..ebfa59778836
--- /dev/null
+++ b/dev-python/tzlocal/tzlocal-5.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="tzinfo object for the local timezone"
+HOMEPAGE="
+ https://github.com/regebro/tzlocal/
+ https://pypi.org/project/tzlocal/
+"
+# symlinks aren't correctly preserved in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/regebro/tzlocal/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest