summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/unidecode/unidecode-1.3.8.ebuild')
-rw-r--r--dev-python/unidecode/unidecode-1.3.8.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/unidecode/unidecode-1.3.8.ebuild b/dev-python/unidecode/unidecode-1.3.8.ebuild
new file mode 100644
index 000000000000..90786226cabb
--- /dev/null
+++ b/dev-python/unidecode/unidecode-1.3.8.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Module providing ASCII transliterations of Unicode text"
+HOMEPAGE="https://pypi.org/project/Unidecode/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ppc ppc64 ~riscv sparc x86"
+
+distutils_enable_tests unittest