summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/whoosh/whoosh-2.7.3.ebuild')
-rw-r--r--dev-python/whoosh/whoosh-2.7.3.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/whoosh/whoosh-2.7.3.ebuild b/dev-python/whoosh/whoosh-2.7.3.ebuild
deleted file mode 100644
index f75fd4897278..000000000000
--- a/dev-python/whoosh/whoosh-2.7.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-MY_PN="Whoosh"
-
-inherit distutils-r1
-
-DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library"
-HOMEPAGE="https://bitbucket.org/mchaput/whoosh/wiki/Home/ https://pypi.python.org/pypi/Whoosh/"
-SRC_URI="mirror://pypi/W/${MY_PN}/${MY_PN}-${PV}.zip"
-
-DEPEND="app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_prepare_all() {
- # (backport from upstream)
- sed -i -e '/cmdclass/s:pytest:PyTest:' setup.py || die
-
- # Prevent un-needed download during build
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- # https://bitbucket.org/mchaput/whoosh/issue/403/
- use doc && sphinx-build -b html -c docs/source/ docs/source/ docs/source/build/html
-}
-
-python_test() {
- # https://bitbucket.org/mchaput/whoosh/issue/412/tarball-of-whoosh-270-pypi-missing-english
- # tarball missing a file english-words.10.gz which when added sees all tests pass.
- esetup.py test
-}
-
-python_install_all() {
- local DOCS=( README.txt )
- use doc && local HTML_DOCS=( docs/source/build/html/. )
- distutils-r1_python_install_all
-}