summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zeep/zeep-4.1.0-r2.ebuild')
-rw-r--r--dev-python/zeep/zeep-4.1.0-r2.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/zeep/zeep-4.1.0-r2.ebuild b/dev-python/zeep/zeep-4.1.0-r2.ebuild
deleted file mode 100644
index a04730a0cc9e..000000000000
--- a/dev-python/zeep/zeep-4.1.0-r2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="A modern/fast Python SOAP client based on lxml / requests"
-HOMEPAGE="https://docs.python-zeep.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="async"
-
-RDEPEND="
- >=dev-python/attrs-17.2.0[${PYTHON_USEDEP}]
- >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
- >=dev-python/lxml-4.6.0[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/requests-file-1.5.1[${PYTHON_USEDEP}]
- >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
- >=dev-python/requests-toolbelt-0.7.1[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- async? ( >=dev-python/aiohttp-1.0[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- test? (
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/aioresponses[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/python-xmlsec[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-httpx[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${P}-cached-prop.patch
-)
-
-EPYTEST_DESELECT=(
- # broken by new pytest-httpx?
- tests/test_async_transport.py::test_load
- tests/test_async_transport.py::test_load_cache
- tests/test_async_transport.py::test_post
- tests/test_async_transport.py::test_http_error
-)