summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/stripe/Manifest5
-rw-r--r--dev-python/stripe/stripe-1.84.2.ebuild21
-rw-r--r--dev-python/stripe/stripe-2.10.1.ebuild71
-rw-r--r--dev-python/stripe/stripe-2.3.0.ebuild22
-rw-r--r--dev-python/stripe/stripe-2.42.0.ebuild (renamed from dev-python/stripe/stripe-2.34.0.ebuild)4
5 files changed, 3 insertions, 120 deletions
diff --git a/dev-python/stripe/Manifest b/dev-python/stripe/Manifest
index 847e343e64f3..1267c0cb868b 100644
--- a/dev-python/stripe/Manifest
+++ b/dev-python/stripe/Manifest
@@ -1,4 +1 @@
-DIST stripe-1.84.2.tar.gz 213050 BLAKE2B df6c195a183d15bdeb7ffbfd2f5683b0b667e8a4df7a637d3960369e1b00a90c74bb5d97af64c553e2f250b2bb7bb698d015a65c3da312f74bc7b141c4b63dc5 SHA512 7d3e1a20c30b3c2fa087c9fe86b04462db4b6cd742ea13daae2754ee6b414656847057b30db48634c6d02ef01d8e510359505fab212325a3db36dfaf2d72db38
-DIST stripe-2.10.1.tar.gz 218299 BLAKE2B b1d836ef92dabfd5a5f292ede69264886dadb0b87b72927e444d615e9f0518efff513f34f2aaee778921f7cb68169f7981a5e84993b19221ec394a1d5c07c622 SHA512 877a87e848d425f333ad3e40c172010a3b1882de0894ff8c5c0623f5d09fbd7ab51d9d53ead8773d3680cdab8d07df32f4210abc08c796adf6feeb4014b671f7
-DIST stripe-2.3.0.tar.gz 213813 BLAKE2B b383c724331d5ec21452aee2eee49c789e2503057c4648d9e879fc561b87cc70ba918bb1e620db3bca380150e62d41433f1bfa7f9b6f164731d3d68542d5f056 SHA512 ba88b18b7328d917379d8474373a1f87717d67cf305022b80eb05c74b8055b825cf30cc879c4e99dbe06dc99f03464649e637d83d70c902b84f5873dd0776453
-DIST stripe-2.34.0.tar.gz 206926 BLAKE2B 30a4d3da4ad58ffb8656c03d1755e20afd7059cf23a693e59af467720e88769f64e53bf62b06c493f7713c50bc251f475501d37045ed0db1df99c9fad72f51eb SHA512 e9bde04ffcd7bfd36afa1a32a9f9bf3454cc262ec2b760bc606aa6b24f8b0d8d0fa37309fc5472ba88dc63f1384c03fc451d2b6a6007728a8ec9fd0899b8b717
+DIST stripe-2.42.0.tar.gz 217456 BLAKE2B 0bd0b31ab1a9a004932ea20b20d7965c05aee12c26d9a6f41af16179fd4c73f9ea08140a157a6ce502a2fb0668de6ac75da869cabf22011977d9912661e85d05 SHA512 acffae91f19c943efe5f4a19f34ff35f8ef0b538e6cf83be6c4820020ad062f7e19365a8edfc048bc24306690dc50b66856526202f5c8830a85a86405f31db50
diff --git a/dev-python/stripe/stripe-1.84.2.ebuild b/dev-python/stripe/stripe-1.84.2.ebuild
deleted file mode 100644
index f4b272ecc1f2..000000000000
--- a/dev-python/stripe/stripe-1.84.2.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-inherit distutils-r1
-
-DESCRIPTION="Stripe python bindings"
-HOMEPAGE="https://github.com/stripe/stripe-python"
-SRC_URI="mirror://pypi/s/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-python/requests-0.8.8"
-DEPEND="${RDEPEND}"
-
-DOCS="LONG_DESCRIPTION.rst"
diff --git a/dev-python/stripe/stripe-2.10.1.ebuild b/dev-python/stripe/stripe-2.10.1.ebuild
deleted file mode 100644
index edb3c66b5c30..000000000000
--- a/dev-python/stripe/stripe-2.10.1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Stripe python bindings"
-HOMEPAGE="https://github.com/stripe/stripe-python"
-SRC_URI="mirror://pypi/s/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- $(python_gen_cond_dep '>=dev-python/requests-2[${PYTHON_USEDEP}]' 'python3*' pypy3)
- $(python_gen_cond_dep '>=dev-python/requests-2[ssl,${PYTHON_USEDEP}]' 'python2*' pypy)
-"
-# See https://github.com/stripe/stripe-python/blob/v2.10.1/tests/conftest.py#L17
-# for minimum required version of stripe-mock
-# Running the tests against dev-util/stripe-mock-0.47.0 resulted in test errors
-DEPEND="${RDEPEND}
- test? (
- >=dev-util/stripe-mock-0.33.0
- <dev-util/stripe-mock-0.47.0
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- net-misc/curl
- )
-"
-
-DOCS=(LONG_DESCRIPTION.rst CHANGELOG.md README.md)
-
-src_test() {
- local stripe_mock_port=12111
- local stripe_mock_max_port=12121
- local stripe_mock_logfile="${T}/stripe_mock_${EPYTHON}.log"
- # Try to start stripe-mock until we find a free port
- while [[ "${stripe_mock_port}" -le "${stripe_mock_max_port}" ]]; do
- ebegin "Trying to start stripe-mock on port ${stripe_mock_port}"
- stripe-mock --http-port ${stripe_mock_port} &> "${stripe_mock_logfile}" &
- local stripe_mock_pid=$!
- sleep 2
- # Did stripe-mock start?
- curl --fail -u "sk_test_123:" \
- http://127.0.0.1:${stripe_mock_port}/v1/customers &> /dev/null
- eend $? "Port ${stripe_mock_port} unavailable"
- if [[ $? -eq 0 ]]; then
- einfo "stripe-mock running on port ${stripe_mock_port}"
- break
- fi
- (( stripe_mock_port++ ))
- done
- if [[ "${stripe_mock_port}" -gt "${stripe_mock_max_port}" ]]; then
- eerror "Unable to start stripe-mock for tests"
- die "Please see the logfile located at: ${stripe_mock_logfile}"
- fi
-
- distutils-r1_src_test
-
- # Tear down stripe-mock
- kill "${stripe_mock_pid}" || die "Unable to stop stripe-mock"
-}
-
-python_test() {
- STRIPE_MOCK_PORT=${stripe_mock_port} pytest -vv || die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/stripe/stripe-2.3.0.ebuild b/dev-python/stripe/stripe-2.3.0.ebuild
deleted file mode 100644
index 9def1b79b23b..000000000000
--- a/dev-python/stripe/stripe-2.3.0.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-inherit distutils-r1
-
-DESCRIPTION="Stripe python bindings"
-HOMEPAGE="https://github.com/stripe/stripe-python"
-SRC_URI="mirror://pypi/s/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/requests-0.8.8"
-DEPEND="${RDEPEND}"
-
-DOCS="LONG_DESCRIPTION.rst CHANGELOG.md README.md"
diff --git a/dev-python/stripe/stripe-2.34.0.ebuild b/dev-python/stripe/stripe-2.42.0.ebuild
index 1eec06317a28..57bfa6b7a472 100644
--- a/dev-python/stripe/stripe-2.34.0.ebuild
+++ b/dev-python/stripe/stripe-2.42.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} pypy3 )
+PYTHON_COMPAT=( python3_{6,7} pypy{,3} )
inherit distutils-r1
DESCRIPTION="Stripe python bindings"
@@ -25,7 +25,7 @@ RDEPEND="
# Running the tests against dev-util/stripe-mock-0.47.0 resulted in test errors
DEPEND="${RDEPEND}
test? (
- >=dev-util/stripe-mock-0.63.0
+ >=dev-util/stripe-mock-0.76.0
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
net-misc/curl