summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-1.9.3.ebuild')
-rw-r--r--dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-1.9.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-1.9.3.ebuild b/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-1.9.3.ebuild
new file mode 100644
index 000000000000..4a0b0ad21ace
--- /dev/null
+++ b/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-1.9.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Plugin to image_transport for transparently sending depth images using PNG compression"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/image_transport
+ media-libs/opencv
+"
+DEPEND="${RDEPEND}"