summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/fake_localization')
-rw-r--r--dev-ros/fake_localization/fake_localization-1.16.2.ebuild3
-rw-r--r--dev-ros/fake_localization/files/boost170.patch13
2 files changed, 15 insertions, 1 deletions
diff --git a/dev-ros/fake_localization/fake_localization-1.16.2.ebuild b/dev-ros/fake_localization/fake_localization-1.16.2.ebuild
index 0c7895911491..946772aaddd8 100644
--- a/dev-ros/fake_localization/fake_localization-1.16.2.ebuild
+++ b/dev-ros/fake_localization/fake_localization-1.16.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -27,3 +27,4 @@ RDEPEND="
dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/boost170.patch" )
diff --git a/dev-ros/fake_localization/files/boost170.patch b/dev-ros/fake_localization/files/boost170.patch
new file mode 100644
index 000000000000..b7f877a82b4f
--- /dev/null
+++ b/dev-ros/fake_localization/files/boost170.patch
@@ -0,0 +1,13 @@
+Index: fake_localization/CMakeLists.txt
+===================================================================
+--- fake_localization.orig/CMakeLists.txt
++++ fake_localization/CMakeLists.txt
+@@ -14,7 +14,7 @@ find_package(catkin REQUIRED
+ )
+
+
+-find_package(Boost REQUIRED COMPONENTS signals)
++find_package(Boost REQUIRED COMPONENTS)
+
+ catkin_package(
+ CATKIN_DEPENDS