summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/joint_state_publisher/joint_state_publisher-1.12.13.ebuild')
-rw-r--r--dev-ros/joint_state_publisher/joint_state_publisher-1.12.13.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/joint_state_publisher/joint_state_publisher-1.12.13.ebuild b/dev-ros/joint_state_publisher/joint_state_publisher-1.12.13.ebuild
new file mode 100644
index 000000000000..5f4325158a53
--- /dev/null
+++ b/dev-ros/joint_state_publisher/joint_state_publisher-1.12.13.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/joint_state_publisher"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for setting and publishing joint state values for a given URDF"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${DEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"