summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosparam/rosparam-1.12.1.ebuild')
-rw-r--r--dev-ros/rosparam/rosparam-1.12.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosparam/rosparam-1.12.1.ebuild b/dev-ros/rosparam/rosparam-1.12.1.ebuild
new file mode 100644
index 000000000000..608ff1c36d31
--- /dev/null
+++ b/dev-ros/rosparam/rosparam-1.12.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for getting and setting ROS Parameters on the parameter server"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"