summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rotate_recovery/rotate_recovery-9999.ebuild')
-rw-r--r--dev-ros/rotate_recovery/rotate_recovery-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/rotate_recovery/rotate_recovery-9999.ebuild b/dev-ros/rotate_recovery/rotate_recovery-9999.ebuild
new file mode 100644
index 000000000000..0d6f07bd8a4a
--- /dev/null
+++ b/dev-ros/rotate_recovery/rotate_recovery-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Recovery behavior that attempts to clear space by performing a 360 degree rotation of the robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/costmap_2d
+ dev-ros/nav_core
+ dev-ros/pluginlib
+ dev-ros/base_local_planner
+ dev-cpp/eigen:3
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules"