summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/activeresource')
-rw-r--r--dev-ruby/activeresource/Manifest2
-rw-r--r--dev-ruby/activeresource/activeresource-3.2.22.ebuild44
-rw-r--r--dev-ruby/activeresource/activeresource-4.0.0.ebuild46
-rw-r--r--dev-ruby/activeresource/metadata.xml8
4 files changed, 100 insertions, 0 deletions
diff --git a/dev-ruby/activeresource/Manifest b/dev-ruby/activeresource/Manifest
new file mode 100644
index 000000000000..e63317b15480
--- /dev/null
+++ b/dev-ruby/activeresource/Manifest
@@ -0,0 +1,2 @@
+DIST activeresource-4.0.0.tgz 69142 SHA256 b2f8094b56c589193fa9c275e4a970fdcd4eb7e7885c8a7a12c86eda6c8d2f37 SHA512 bad94922b7125f79988fb8c6694d6a0370ff1271b47d031e1c249441079e98f75a8069602c1eebf2ec8d7e28aab21b0ca42502c79fe06f46dfa5d42659ff79ab WHIRLPOOL 04120c0a81e140435194ae28a98b4c2ba69e3ef663b7fbf02783839b842c92db70742e4c5d204168dfe4a28caac8d3a8d4c2aea81842959819590544b648d867
+DIST rails-3.2.22.tgz 3569215 SHA256 a14fbd69cd1750589cb6f4a79926058595de832dab89372fb479feadc99f0aba SHA512 7321e5fa12cc3f7d6e7c2284f37c183c9bcbe1c9f067c2be5ebdd10f550b0eff561b20558cf885f30b24951bfa88287b3e0fb421eee14579a88a2bcffeaff3ce WHIRLPOOL de54798cbcbf9a0c6d66346267cfbb15991478cc6b4982f9e3a3a80db734af6553f9749b18188c4dc5fa82c60c0294312f648a0e4b5bcb46896bfee75be4dbc0
diff --git a/dev-ruby/activeresource/activeresource-3.2.22.ebuild b/dev-ruby/activeresource/activeresource-3.2.22.ebuild
new file mode 100644
index 000000000000..96de5c5f938e
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-3.2.22.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Think Active Record for web resources"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ dev-ruby/builder:3"
+ruby_add_bdepend "
+ test? (
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.13.0:0.13
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Make sure we use the test-unit gem since ruby18 does not provide
+ # all the test-unit features needed.
+ sed -i -e '1igem "test-unit"' test/abstract_unit.rb || die
+}
diff --git a/dev-ruby/activeresource/activeresource-4.0.0.ebuild b/dev-ruby/activeresource/activeresource-4.0.0.ebuild
new file mode 100644
index 000000000000..42434cd319f6
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-4.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Think Active Record for web resources"
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+SRC_URI="http://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64"
+IUSE=""
+
+#RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "=dev-ruby/activesupport-4*
+ =dev-ruby/activemodel-4*
+ >=dev-ruby/rails-observers-0.1.1:0.1"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.13.0:0.13
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm Gemfile || die "Unable to remove Gemfile"
+
+ # Pull in the correct version of minitest since we don't use bundler.
+ sed -i -e '1igem "minitest", "~>4.0"' \
+ -e '2igem "activemodel", "~>4.0.0"' test/abstract_unit.rb || die
+
+}
diff --git a/dev-ruby/activeresource/metadata.xml b/dev-ruby/activeresource/metadata.xml
new file mode 100644
index 000000000000..b7b7a6aa1d83
--- /dev/null
+++ b/dev-ruby/activeresource/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">rails/activeresource</remote-id>
+ </upstream>
+</pkgmetadata>