summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/addressable')
-rw-r--r--dev-ruby/addressable/Manifest3
-rw-r--r--dev-ruby/addressable/addressable-2.3.6.ebuild39
-rw-r--r--dev-ruby/addressable/addressable-2.3.7.ebuild39
-rw-r--r--dev-ruby/addressable/addressable-2.3.8.ebuild39
-rw-r--r--dev-ruby/addressable/metadata.xml8
5 files changed, 128 insertions, 0 deletions
diff --git a/dev-ruby/addressable/Manifest b/dev-ruby/addressable/Manifest
new file mode 100644
index 000000000000..13ecadcb1a97
--- /dev/null
+++ b/dev-ruby/addressable/Manifest
@@ -0,0 +1,3 @@
+DIST addressable-2.3.6.gem 98304 SHA256 e822c28133d151d450778bbcf1f6e7742d4c3aba54498eb0da33d80a3990ee8c SHA512 26a2d754397a5e46bc22ea9755d1c1a1b9f993e38fcf9b0a6133ea6d0aa7bdc0fe6bfe83bc39991e3b258fa3122e44bbd0b0758026be02af2a70ffef96d0dfa4 WHIRLPOOL 19ef0436df04172ca5dd9811d75616e069871476df879c10bc711e9db084636ca6edebed7500707d9409d6bd9041ece431609a7e4b2e42121a7cce6989bf5964
+DIST addressable-2.3.7.gem 99328 SHA256 7022baaa16500f065a290cfd2d4926367c10a40421f725582adcea546a0024f4 SHA512 0376757a98997a992b52bf893636e72194fcc745c1e5253e02d405c07e8fc8fa37442f4db86323023dffc04c8bd988085bf97d3e2edcde84b2bdbe98a4f8dfd1 WHIRLPOOL 32e36d2479b8907573c757dd42e77528cf6dcc7b37c3c1d9e690d2b262eb0c979dd6e574d663211ba4f6caf898bd42e140882a8e754c963bd0515c8eb502a609
+DIST addressable-2.3.8.gem 99840 SHA256 a64ef127ac7b0ceed1324dfbccb478e8b0e4b272f6a53a8f11ffbe826a576394 SHA512 56c3f4b95a78af3b35fa0813cc0b010f89c698fefb0c79865af553ba5c2a162b936921de40b2659498812efc1692ed49e95f9984a044c0ed42f96a26b666b5fc WHIRLPOOL 537aa51973efe6c834f02b2bec884f1385132e4923ef633614ffc022c7b9a550ecc83b837aa0b6232f21a163006f7b6bbbdbe8b3df99c39c2008c493dd3c0546
diff --git a/dev-ruby/addressable/addressable-2.3.6.ebuild b/dev-ruby/addressable/addressable-2.3.6.ebuild
new file mode 100644
index 000000000000..373d7ad2aa96
--- /dev/null
+++ b/dev-ruby/addressable/addressable-2.3.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC="doc:yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RAKE_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library"
+HOMEPAGE="https://rubygems.org/gems/addressable https://github.com/sporkmonger/addressable"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+all_ruby_prepare() {
+ # Remove spec-related tasks so that we don't need to require rspec
+ # just to build the documentation, bug 383611.
+ sed -i -e '/spectask/d' Rakefile || die
+ rm tasks/rspec.rake || die
+ sed -i -e '/[Cc]overalls/d' spec/spec_helper.rb || die
+
+ # Remove specs requiring network connectivity
+ rm spec/addressable/net_http_compat_spec.rb || die
+}
diff --git a/dev-ruby/addressable/addressable-2.3.7.ebuild b/dev-ruby/addressable/addressable-2.3.7.ebuild
new file mode 100644
index 000000000000..6d6a2014bc20
--- /dev/null
+++ b/dev-ruby/addressable/addressable-2.3.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC="doc:yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RAKE_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library"
+HOMEPAGE="https://rubygems.org/gems/addressable https://github.com/sporkmonger/addressable"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+all_ruby_prepare() {
+ # Remove spec-related tasks so that we don't need to require rspec
+ # just to build the documentation, bug 383611.
+ sed -i -e '/spectask/d' Rakefile || die
+ rm tasks/rspec.rake || die
+ sed -i -e '/[Cc]overalls/d' spec/spec_helper.rb || die
+
+ # Remove specs requiring network connectivity
+ rm spec/addressable/net_http_compat_spec.rb || die
+}
diff --git a/dev-ruby/addressable/addressable-2.3.8.ebuild b/dev-ruby/addressable/addressable-2.3.8.ebuild
new file mode 100644
index 000000000000..fe6d0fe07c05
--- /dev/null
+++ b/dev-ruby/addressable/addressable-2.3.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC="doc:yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RAKE_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library"
+HOMEPAGE="https://rubygems.org/gems/addressable https://github.com/sporkmonger/addressable"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ # Remove spec-related tasks so that we don't need to require rspec
+ # just to build the documentation, bug 383611.
+ sed -i -e '/spectask/d' Rakefile || die
+ rm tasks/rspec.rake || die
+ sed -i -e '/[Cc]overalls/d' spec/spec_helper.rb || die
+
+ # Remove specs requiring network connectivity
+ rm spec/addressable/net_http_compat_spec.rb || die
+}
diff --git a/dev-ruby/addressable/metadata.xml b/dev-ruby/addressable/metadata.xml
new file mode 100644
index 000000000000..fb7bffedbcce
--- /dev/null
+++ b/dev-ruby/addressable/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">sporkmonger/addressable</remote-id>
+ </upstream>
+</pkgmetadata>