summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ascii85/ascii85-1.0.2-r2.ebuild')
-rw-r--r--dev-ruby/ascii85/ascii85-1.0.2-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/ascii85/ascii85-1.0.2-r2.ebuild b/dev-ruby/ascii85/ascii85-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..446bdc323d8d
--- /dev/null
+++ b/dev-ruby/ascii85/ascii85-1.0.2-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.txt"
+
+RUBY_FAKEGEM_NAME="Ascii85"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Methods for encoding/decoding Adobe's binary-to-text encoding of the same name"
+HOMEPAGE="https://github.com/datawraith/ascii85gem"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+}