summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/color/color-1.7.1.ebuild')
-rw-r--r--dev-ruby/color/color-1.7.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/color/color-1.7.1.ebuild b/dev-ruby/color/color-1.7.1.ebuild
new file mode 100644
index 000000000000..3926d934cea3
--- /dev/null
+++ b/dev-ruby/color/color-1.7.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Colour management with Ruby"
+HOMEPAGE="http://color.rubyforge.org/"
+SRC_URI="https://github.com/halostatue/color/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/minitest-5.0
+ )"
+
+each_ruby_test() {
+ ${RUBY} -S testrb -Ilib test/test_*.rb || die
+}