summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ethon/ethon-0.7.1.ebuild')
-rw-r--r--dev-ruby/ethon/ethon-0.7.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/ethon/ethon-0.7.1.ebuild b/dev-ruby/ethon/ethon-0.7.1.ebuild
new file mode 100644
index 000000000000..861631cd5700
--- /dev/null
+++ b/dev-ruby/ethon/ethon-0.7.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Very lightweight libcurl wrapper"
+HOMEPAGE="https://github.com/typhoeus/ethon"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND+="net-misc/curl"
+
+ruby_add_rdepend ">=dev-ruby/ffi-1.3.0"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' -i Rakefile spec/spec_helper.rb || die
+}