summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/git')
-rw-r--r--dev-ruby/git/Manifest1
-rw-r--r--dev-ruby/git/git-1.2.9.1-r1.ebuild38
-rw-r--r--dev-ruby/git/git-1.2.9.1.ebuild38
-rw-r--r--dev-ruby/git/metadata.xml8
4 files changed, 85 insertions, 0 deletions
diff --git a/dev-ruby/git/Manifest b/dev-ruby/git/Manifest
new file mode 100644
index 000000000000..653c1736614d
--- /dev/null
+++ b/dev-ruby/git/Manifest
@@ -0,0 +1 @@
+DIST git-1.2.9.1.tar.gz 124499 SHA256 4c260dcb8103eb6410386352859884fdfcb8246a0d8b1ec9f0feb8c33e10ef23 SHA512 81a4886c82528a5777e27711b6fa69a2a57f774db097fdc53ccc5a3726bee5f153a8d70ae9f8c6b458ebf52df12ce87898452796ea5e73a76ea0c8823674d0c6 WHIRLPOOL b2ad73b34d599e1d1b3dbc1cf006f507bcb26eeea6556191e77cf70c1c092fe4f1f769189b9359dc39a3d381f422f217657f72840955fcb63b37e1e21bedcd8b
diff --git a/dev-ruby/git/git-1.2.9.1-r1.ebuild b/dev-ruby/git/git-1.2.9.1-r1.ebuild
new file mode 100644
index 000000000000..be39c815362a
--- /dev/null
+++ b/dev-ruby/git/git-1.2.9.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+RUBY_FAKEGEM_GEMSPEC="git.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for using Git in Ruby"
+HOMEPAGE="http://github.com/schacon/ruby-git"
+SRC_URI="https://github.com/schacon/ruby-git/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-git-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND+="test? ( >=dev-vcs/git-1.6.0.0 app-arch/tar )"
+RDEPEND+=">=dev-vcs/git-1.6.0.0"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ # Needs test-unit, the test-unit version distributed with ruby19 is
+ # not good enough.
+ sed -i -e '3igem "test-unit"' Rakefile || die
+
+ # Don't use hardcoded /tmp directory.
+ sed -i -e "s:/tmp:${TMPDIR}:" tests/units/test_archive.rb tests/test_helper.rb || die
+}
diff --git a/dev-ruby/git/git-1.2.9.1.ebuild b/dev-ruby/git/git-1.2.9.1.ebuild
new file mode 100644
index 000000000000..ba68e818ade8
--- /dev/null
+++ b/dev-ruby/git/git-1.2.9.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+RUBY_FAKEGEM_GEMSPEC="git.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for using Git in Ruby"
+HOMEPAGE="http://github.com/schacon/ruby-git"
+SRC_URI="https://github.com/schacon/ruby-git/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-git-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND+="test? ( >=dev-vcs/git-1.6.0.0 app-arch/tar )"
+RDEPEND+=">=dev-vcs/git-1.6.0.0"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ # Needs test-unit, the test-unit version distributed with ruby19 is
+ # not good enough.
+ sed -i -e '3igem "test-unit"' Rakefile || die
+
+ # Don't use hardcoded /tmp directory.
+ sed -i -e "s:/tmp:${TMPDIR}:" tests/units/test_archive.rb tests/test_helper.rb || die
+}
diff --git a/dev-ruby/git/metadata.xml b/dev-ruby/git/metadata.xml
new file mode 100644
index 000000000000..be56a9286982
--- /dev/null
+++ b/dev-ruby/git/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">schacon/ruby-git</remote-id>
+ </upstream>
+</pkgmetadata>