summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/heredoc_unindent/heredoc_unindent-1.1.2-r3.ebuild')
-rw-r--r--dev-ruby/heredoc_unindent/heredoc_unindent-1.1.2-r3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/heredoc_unindent/heredoc_unindent-1.1.2-r3.ebuild b/dev-ruby/heredoc_unindent/heredoc_unindent-1.1.2-r3.ebuild
new file mode 100644
index 000000000000..142de0139a0e
--- /dev/null
+++ b/dev-ruby/heredoc_unindent/heredoc_unindent-1.1.2-r3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc Wishlist.rdoc"
+DESCRIPTION="Removes leading whitespace from Ruby heredocs"
+HOMEPAGE="https://github.com/adrianomitre/heredoc_unindent"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="doc test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/hoe-2.8.0 dev-ruby/test-unit:2 )
+ doc? ( >=dev-ruby/hoe-2.8.0 )"
+
+all_ruby_prepare() {
+ sed -i -e '1igem "test-unit"' test/test_heredoc_unindent.rb || die
+}