summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/kpeg')
-rw-r--r--dev-ruby/kpeg/files/kpeg-1.1.0-utf8.patch17
-rw-r--r--dev-ruby/kpeg/kpeg-1.1.0-r1.ebuild25
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/kpeg/files/kpeg-1.1.0-utf8.patch b/dev-ruby/kpeg/files/kpeg-1.1.0-utf8.patch
new file mode 100644
index 000000000000..1b565c466c2d
--- /dev/null
+++ b/dev-ruby/kpeg/files/kpeg-1.1.0-utf8.patch
@@ -0,0 +1,17 @@
+Ensure proper encoding in non-UTF-8 locales.
+
+https://bugs.gentoo.org/640150
+
+--- a/lib/kpeg/grammar.rb.orig 2018-05-20 09:26:13.597648830 +0200
++++ b/lib/kpeg/grammar.rb 2018-05-20 09:28:19.606460712 +0200
+@@ -130,6 +130,10 @@
+ end
+ end
+
++ if reg =~ /\{[LMNPSZC][c-u]?\}/ && reg.encoding != Encoding::UTF_8
++ reg.force_encoding('UTF-8')
++ end
++
+ @regexp = Regexp.new(reg, flags, lang)
+ else
+ @regexp = reg
diff --git a/dev-ruby/kpeg/kpeg-1.1.0-r1.ebuild b/dev-ruby/kpeg/kpeg-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..52d864e2684f
--- /dev/null
+++ b/dev-ruby/kpeg/kpeg-1.1.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple PEG library for Ruby"
+HOMEPAGE="https://github.com/evanphx/kpeg"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+PATCHES=( "${FILESDIR}/${P}-utf8.patch" )
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'gem "minitest", "~>5.0"; Dir["test/test_*.rb"].each{|f| require f}' || die
+}