summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/multi_xml/multi_xml-0.5.4-r1.ebuild')
-rw-r--r--dev-ruby/multi_xml/multi_xml-0.5.4-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/multi_xml/multi_xml-0.5.4-r1.ebuild b/dev-ruby/multi_xml/multi_xml-0.5.4-r1.ebuild
new file mode 100644
index 000000000000..71e7401a21ef
--- /dev/null
+++ b/dev-ruby/multi_xml/multi_xml-0.5.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC="doc:yard"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A generic swappable back-end for XML parsing"
+HOMEPAGE="http://rdoc.info/gems/multi_xml"
+LICENSE="MIT"
+
+KEYWORDS="amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/SimpleCov.start/ s:^:#:' spec/helper.rb || die
+}
+
+each_ruby_test() {
+ CI=true each_fakegem_test
+}