summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/nanotest')
-rw-r--r--dev-ruby/nanotest/Manifest1
-rw-r--r--dev-ruby/nanotest/metadata.xml8
-rw-r--r--dev-ruby/nanotest/nanotest-0.9.4.1.ebuild23
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/nanotest/Manifest b/dev-ruby/nanotest/Manifest
new file mode 100644
index 000000000000..23a972b1ab4f
--- /dev/null
+++ b/dev-ruby/nanotest/Manifest
@@ -0,0 +1 @@
+DIST nanotest-0.9.4.1.gem 7680 SHA256 6250f14fb560c0a01024cccb8545cfa0b7cae4d555b94ded203d852937d23efb SHA512 0ef48c747130fadb5f11818e131780b05032d57102a142293e29f135f75c1dd57c75005479880974342c257c645b3d2a4489432049683e3421743fa3e252cc09 WHIRLPOOL 331efae90e331fd9c346f63ce2455c25231e1084c97922492e9c82e907362cb11ba1d1587df8bc33314319603ec2350b7d0bb27cd74accfca554bd84b8e292fa
diff --git a/dev-ruby/nanotest/metadata.xml b/dev-ruby/nanotest/metadata.xml
new file mode 100644
index 000000000000..7e0a678c271a
--- /dev/null
+++ b/dev-ruby/nanotest/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">mynyml/nanotest</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/nanotest/nanotest-0.9.4.1.ebuild b/dev-ruby/nanotest/nanotest-0.9.4.1.ebuild
new file mode 100644
index 000000000000..4fb910dd982b
--- /dev/null
+++ b/dev-ruby/nanotest/nanotest-0.9.4.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Extremely mynymal test framework"
+HOMEPAGE="https://github.com/mynyml/nanotest"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -I.:lib test/test_nanotest.rb || die
+}