summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/protected_attributes/protected_attributes-1.1.1.ebuild')
-rw-r--r--dev-ruby/protected_attributes/protected_attributes-1.1.1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-ruby/protected_attributes/protected_attributes-1.1.1.ebuild b/dev-ruby/protected_attributes/protected_attributes-1.1.1.ebuild
deleted file mode 100644
index aeb4f5d78f03..000000000000
--- a/dev-ruby/protected_attributes/protected_attributes-1.1.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
-
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Protect attributes from mass-assignment in ActiveRecord models"
-HOMEPAGE="https://github.com/rails/protected_attributes"
-SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SLOT="1"
-
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-ruby_add_rdepend "
- =dev-ruby/activemodel-4*:* >=dev-ruby/activemodel-4.0.1:*
-"
-
-ruby_add_bdepend "test? (
- dev-ruby/bundler
- =dev-ruby/actionpack-4*
- =dev-ruby/activerecord-4*
- =dev-ruby/rails-4*
- dev-ruby/mocha
- dev-ruby/sqlite3
-)"
-
-all_ruby_prepare() {
- sed -i -e '/github/ s:^:#:' Gemfile || die
-}