summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/psych/psych-2.0.11.ebuild')
-rw-r--r--dev-ruby/psych/psych-2.0.11.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/psych/psych-2.0.11.ebuild b/dev-ruby/psych/psych-2.0.11.ebuild
new file mode 100644
index 000000000000..c33c1e670c65
--- /dev/null
+++ b/dev-ruby/psych/psych-2.0.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A libyaml wrapper for Ruby"
+HOMEPAGE="https://github.com/tenderlove/psych"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" >=dev-libs/libyaml-0.1.6"
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-4.0:0 )"
+
+all_ruby_prepare() {
+ sed -i -e '1igem "minitest", "~>4.0"' test/psych/helper.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/${PN}$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:test/${PN}:. -e "Dir['test/psych/**/test_*.rb'].each {|f| require f}" || die
+}