summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rex-bin_tools/rex-bin_tools-0.1.2.ebuild')
-rw-r--r--dev-ruby/rex-bin_tools/rex-bin_tools-0.1.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/rex-bin_tools/rex-bin_tools-0.1.2.ebuild b/dev-ruby/rex-bin_tools/rex-bin_tools-0.1.2.ebuild
new file mode 100644
index 000000000000..39638d1020e8
--- /dev/null
+++ b/dev-ruby/rex-bin_tools/rex-bin_tools-0.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="suite of tools for analyzing executables to find specific chunks of code"
+HOMEPAGE="https://rubygems.org/gems/rex-bin_tools"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+RESTRICT="test"
+
+ruby_add_rdepend "dev-ruby/rex-arch
+ dev-ruby/metasm:*
+ dev-ruby/rex-core
+ dev-ruby/rex-struct2
+ dev-ruby/rex-text"
+
+all_ruby_prepare() {
+ sed -i '/bundler/d' Rakefile
+}