summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rinku')
-rw-r--r--dev-ruby/rinku/Manifest1
-rw-r--r--dev-ruby/rinku/metadata.xml8
-rw-r--r--dev-ruby/rinku/rinku-1.7.3.ebuild32
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/rinku/Manifest b/dev-ruby/rinku/Manifest
new file mode 100644
index 000000000000..88a94cd5aaa9
--- /dev/null
+++ b/dev-ruby/rinku/Manifest
@@ -0,0 +1 @@
+DIST rinku-1.7.3.gem 16384 SHA256 eb5cec33af86da3002e66470d9a741a0726d6864a69b580abc798931b4b706ca SHA512 6cd56d21f9366ca1550d62b864f3160f8426412caefb47343152c856a122e729c6e38d339075bdda8614e36c3c5f498001c0e943db455e55ee401e9cdf320c94 WHIRLPOOL 8c9b365dace46b58f4e8b3c70a5b98cb90aa383c1e40cea0c0919f58c4a7ea94cfb44b07415fd9044a09a76e8a70d03fc10b13556f0e89fbea4b81c3ecad02bb
diff --git a/dev-ruby/rinku/metadata.xml b/dev-ruby/rinku/metadata.xml
new file mode 100644
index 000000000000..c5b801be96ba
--- /dev/null
+++ b/dev-ruby/rinku/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">vmg/rinku</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rinku/rinku-1.7.3.ebuild b/dev-ruby/rinku/rinku-1.7.3.ebuild
new file mode 100644
index 000000000000..a5f427b687ca
--- /dev/null
+++ b/dev-ruby/rinku/rinku-1.7.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A Ruby library that does autolinking"
+HOMEPAGE="https://github.com/vmg/rinku"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/${PN}$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/autolink_test.rb || die
+}