summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rubypants/rubypants-0.5.1.ebuild')
-rw-r--r--dev-ruby/rubypants/rubypants-0.5.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rubypants/rubypants-0.5.1.ebuild b/dev-ruby/rubypants/rubypants-0.5.1.ebuild
new file mode 100644
index 000000000000..a95975b6612a
--- /dev/null
+++ b/dev-ruby/rubypants/rubypants-0.5.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby port of the SmartyPants PHP library"
+HOMEPAGE="http://chneukirchen.org/repos/rubypants/README"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -I. test/rubypants_test.rb || die "tests failed"
+}