summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/shoulda-matchers')
-rw-r--r--dev-ruby/shoulda-matchers/shoulda-matchers-2.8.0-r1.ebuild25
-rw-r--r--dev-ruby/shoulda-matchers/shoulda-matchers-3.1.1-r1.ebuild25
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-ruby/shoulda-matchers/shoulda-matchers-2.8.0-r1.ebuild b/dev-ruby/shoulda-matchers/shoulda-matchers-2.8.0-r1.ebuild
new file mode 100644
index 000000000000..edacf73b4d31
--- /dev/null
+++ b/dev-ruby/shoulda-matchers/shoulda-matchers-2.8.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_RECIPE_TEST=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="NEWS.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Making tests easy on the fingers and eyes"
+HOMEPAGE="https://github.com/thoughtbot/shoulda-matchers"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activesupport-3.0.0"
diff --git a/dev-ruby/shoulda-matchers/shoulda-matchers-3.1.1-r1.ebuild b/dev-ruby/shoulda-matchers/shoulda-matchers-3.1.1-r1.ebuild
new file mode 100644
index 000000000000..98d41b02a3c0
--- /dev/null
+++ b/dev-ruby/shoulda-matchers/shoulda-matchers-3.1.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_RECIPE_TEST=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="NEWS.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Making tests easy on the fingers and eyes"
+HOMEPAGE="https://github.com/thoughtbot/shoulda-matchers"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activesupport-4.0.0:*"