summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/temple')
-rw-r--r--dev-ruby/temple/Manifest2
-rw-r--r--dev-ruby/temple/metadata.xml8
-rw-r--r--dev-ruby/temple/temple-0.6.10.ebuild33
-rw-r--r--dev-ruby/temple/temple-0.7.6.ebuild29
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-ruby/temple/Manifest b/dev-ruby/temple/Manifest
new file mode 100644
index 000000000000..7608fa9310da
--- /dev/null
+++ b/dev-ruby/temple/Manifest
@@ -0,0 +1,2 @@
+DIST temple-0.6.10.gem 36864 SHA256 0161614497136071cf02cd88f18e9fd0d1d9598552181c6a11e7a4a7e322ffd3 SHA512 668d4b12ff2f5b28fa70755036c4b2d4612ee6fd0f66382cc534d5e1555e0105e6efff58ddfdadc62dd0a0f0066fe37ac9228299258a045ba7af7ad73600ba83 WHIRLPOOL d00aab4925212ff2573ba7b1bb9efe6646b18068ae721347fa53dc75d1d92054fe575f3a0f84c80021530d9ba16f68665a1c61ae051442faf240f974a509a12c
+DIST temple-0.7.6.gem 36864 SHA256 60c10cdab98d9023905ce4bf1ae497419ea5649cd9b75d3e016bd2b32555597b SHA512 9b75e59dd07352f712fa8021bb25d327a470735f27a0283054de34b1aa20b6443098da3b8cf350b1a23ad25e61ef1e024d0ef93b28714d06e32f76af9718f6a5 WHIRLPOOL bcf6ccb9b8c7bfd30779142f12c9166765045689515517ee9bcccdecc720fb2778f92ff8c4be266ec0a4a480fd9de72de78ec3c3990b672e5e7fff4c1ab2a9f7
diff --git a/dev-ruby/temple/metadata.xml b/dev-ruby/temple/metadata.xml
new file mode 100644
index 000000000000..c57536b87990
--- /dev/null
+++ b/dev-ruby/temple/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">judofyr/temple</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/temple/temple-0.6.10.ebuild b/dev-ruby/temple/temple-0.6.10.ebuild
new file mode 100644
index 000000000000..83003bd45ae6
--- /dev/null
+++ b/dev-ruby/temple/temple-0.6.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES EXPRESSIONS.md README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="An abstraction and a framework for compiling templates to pure Ruby"
+HOMEPAGE="https://github.com/judofyr/temple"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ # Avoid test failing based on specific load ordering
+ sed -i -e '/should have use_html_safe option/,/^ end/ s:^:#:' \
+ test/filters/test_escapable.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test -S bacon --automatic --quiet || die
+}
diff --git a/dev-ruby/temple/temple-0.7.6.ebuild b/dev-ruby/temple/temple-0.7.6.ebuild
new file mode 100644
index 000000000000..b62083b16537
--- /dev/null
+++ b/dev-ruby/temple/temple-0.7.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES EXPRESSIONS.md README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="An abstraction and a framework for compiling templates to pure Ruby"
+HOMEPAGE="https://github.com/judofyr/temple"
+
+LICENSE="MIT"
+SLOT="0.7"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bacon
+ dev-ruby/erubis
+ >=dev-ruby/tilt-2.0.1 )"
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Ilib -Itest --automatic --quiet || die
+}