summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/text')
-rw-r--r--dev-ruby/text/Manifest3
-rw-r--r--dev-ruby/text/metadata.xml8
-rw-r--r--dev-ruby/text/text-1.2.3-r1.ebuild20
-rw-r--r--dev-ruby/text/text-1.2.3-r2.ebuild20
-rw-r--r--dev-ruby/text/text-1.3.0.ebuild20
-rw-r--r--dev-ruby/text/text-1.3.1.ebuild20
6 files changed, 91 insertions, 0 deletions
diff --git a/dev-ruby/text/Manifest b/dev-ruby/text/Manifest
new file mode 100644
index 000000000000..d26f5d5261e9
--- /dev/null
+++ b/dev-ruby/text/Manifest
@@ -0,0 +1,3 @@
+DIST text-1.2.3.gem 136192 SHA256 a0e9fb0fa88b6fb5d89e370f898064604f28d0873c342b27235a767dea58e192 SHA512 bc4ad5a00dc8bb7275b5481ce3be1efe1b32a9bb83e818025c0d815c19addf1fa7ed99855ac3188aef5ce54150323a8dc9573bd193e195614731c093fb7fd917 WHIRLPOOL db7d6f2d0472467ee594f05ba8fdbf20159869342d6fba77ff31407428e7eabe6e5b3808cc2aa10d8cf223e544fae10cbe8ab1e28b0621eae85c490eae31141d
+DIST text-1.3.0.gem 138752 SHA256 47b6f8b04e722c91a023e562dde289d0047cd488b18d4e6fd7f71d256a06d6ad SHA512 504c0a60b3ea80c0d5dc89c9987750954980f6aa0fea4ceba9bcae6d81af4a47afa81775816e28fb00d7e02f4bd1ddd53764a0cf669c7691125a3a4bdb92fe0c WHIRLPOOL 55eda2d8d0c3ec0bb41e12e22daafcc7b843ac96e4bd08d5fbffcb6cc350f75a4996bd3648223e61712a6c96feea903f6ba7710c4b6d442d092680d77807693d
+DIST text-1.3.1.gem 138752 SHA256 2fbbbc82c1ce79c4195b13018a87cbb00d762bda39241bb3cdc32792759dd3f4 SHA512 0380fc77e2f0d427afd9015ed904947311139e52adf3d49b748d0e6ee32c579073ec979f0cdbc117b53e3d841f25ce9f271637dd7edb5f6e124e369cca788eb8 WHIRLPOOL 66da2d453d3a4dc332166b5ccabcdb586748d3a3d979a4b7281e69157c04d389a95ff8ecb6727b0952a6dbaba4068f262b856e19c39a7cfd9d296d1eb4b70a91
diff --git a/dev-ruby/text/metadata.xml b/dev-ruby/text/metadata.xml
new file mode 100644
index 000000000000..d492d6eb5e9b
--- /dev/null
+++ b/dev-ruby/text/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">threedaymonk/text</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/text/text-1.2.3-r1.ebuild b/dev-ruby/text/text-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..56f229bea83b
--- /dev/null
+++ b/dev-ruby/text/text-1.2.3-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A collection of text algorithms"
+HOMEPAGE="https://github.com/threedaymonk/text"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
+IUSE=""
diff --git a/dev-ruby/text/text-1.2.3-r2.ebuild b/dev-ruby/text/text-1.2.3-r2.ebuild
new file mode 100644
index 000000000000..76d54f20f1a7
--- /dev/null
+++ b/dev-ruby/text/text-1.2.3-r2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A collection of text algorithms"
+HOMEPAGE="https://github.com/threedaymonk/text"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
diff --git a/dev-ruby/text/text-1.3.0.ebuild b/dev-ruby/text/text-1.3.0.ebuild
new file mode 100644
index 000000000000..a701c365530a
--- /dev/null
+++ b/dev-ruby/text/text-1.3.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A collection of text algorithms"
+HOMEPAGE="https://github.com/threedaymonk/text"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
diff --git a/dev-ruby/text/text-1.3.1.ebuild b/dev-ruby/text/text-1.3.1.ebuild
new file mode 100644
index 000000000000..a701c365530a
--- /dev/null
+++ b/dev-ruby/text/text-1.3.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A collection of text algorithms"
+HOMEPAGE="https://github.com/threedaymonk/text"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""