summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/tokyocabinet')
-rw-r--r--dev-ruby/tokyocabinet/Manifest1
-rw-r--r--dev-ruby/tokyocabinet/metadata.xml5
-rw-r--r--dev-ruby/tokyocabinet/tokyocabinet-1.29.1.ebuild36
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/tokyocabinet/Manifest b/dev-ruby/tokyocabinet/Manifest
new file mode 100644
index 000000000000..8179102a702a
--- /dev/null
+++ b/dev-ruby/tokyocabinet/Manifest
@@ -0,0 +1 @@
+DIST tokyocabinet-1.29.1.gem 18944 SHA256 e1df73a0101532a606abeda37bee483e3707e90ddb502631ec0b028f58fb1fb7 SHA512 c6614644996d2182f07c1f1e025184b42facadaf84dbbc4106ba754ff98ffaa8aa098406dda51ad86eeed7806c89e04c9fad62d2798c63c7203a734de3ab39f8 WHIRLPOOL 00ce07794dba172884f1762e6fcaabb253293bdc7b22dcc241ea83427ea39e08b95e2821138235250d2b9cd370001a921de6cccbeaffee69eaa9960070bdda97
diff --git a/dev-ruby/tokyocabinet/metadata.xml b/dev-ruby/tokyocabinet/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/tokyocabinet/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/tokyocabinet/tokyocabinet-1.29.1.ebuild b/dev-ruby/tokyocabinet/tokyocabinet-1.29.1.ebuild
new file mode 100644
index 000000000000..55fa9ad62d4e
--- /dev/null
+++ b/dev-ruby/tokyocabinet/tokyocabinet-1.29.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby bindings for Tokyo Cabinet"
+HOMEPAGE="http://fallabs.com/tokyocabinet/"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND+="dev-db/tokyocabinet"
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1
+}
+
+each_ruby_install() {
+ emake install DESTDIR="${D}"
+
+ each_fakegem_install
+}