summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tclperl/tclperl-3.2-r2.ebuild')
-rw-r--r--dev-tcltk/tclperl/tclperl-3.2-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-tcltk/tclperl/tclperl-3.2-r2.ebuild b/dev-tcltk/tclperl/tclperl-3.2-r2.ebuild
new file mode 100644
index 000000000000..850c9507c6ff
--- /dev/null
+++ b/dev-tcltk/tclperl/tclperl-3.2-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Perl package for Tcl"
+HOMEPAGE="http://jfontain.free.fr/tclperl.htm"
+SRC_URI="http://jfontain.free.fr/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/tcl-8.3.3:=
+ >=dev-lang/perl-5.6.0:=
+ sys-libs/binutils-libs:="
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGES README)
+HTML_DOCS=( tclperl.htm )
+
+src_compile() {
+ append-flags -fPIC
+
+ # ./build.sh
+ perl Makefile.PL || die
+ emake OPTIMIZE="${CFLAGS}" Tcl.o
+
+ $(tc-getCC) -shared ${LDFLAGS} ${CFLAGS} -o tclperl.so.${PV} -DUSE_TCL_STUBS \
+ tclperl.c tclthread.c `perl -MExtUtils::Embed -e ccopts -e ldopts` \
+ /usr/$(get_libdir)/libtclstub`echo 'puts $tcl_version' | tclsh`.a Tcl.o || die
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/${P}
+ doexe tclperl.so.${PV}
+ doexe pkgIndex.tcl
+ einstalldocs
+}