summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/expect/expect-5.45.4.ebuild4
-rw-r--r--dev-tcltk/expect/files/expect-5.45.4-examples.patch14
2 files changed, 12 insertions, 6 deletions
diff --git a/dev-tcltk/expect/expect-5.45.4.ebuild b/dev-tcltk/expect/expect-5.45.4.ebuild
index 7f5402663564..b6d1a0feefe2 100644
--- a/dev-tcltk/expect/expect-5.45.4.ebuild
+++ b/dev-tcltk/expect/expect-5.45.4.ebuild
@@ -72,6 +72,10 @@ src_install() {
if use doc ; then
docinto examples
+ echo dodoc \
+ example/README \
+ $(printf 'example/%s ' $(expect_make_var _SCRIPTS)) \
+ $(printf 'example/%s.man ' $(expect_make_var _SCRIPTS_MANPAGES))
dodoc \
example/README \
$(printf 'example/%s ' $(expect_make_var _SCRIPTS)) \
diff --git a/dev-tcltk/expect/files/expect-5.45.4-examples.patch b/dev-tcltk/expect/files/expect-5.45.4-examples.patch
index 10de8821a01a..cd631b30a5c1 100644
--- a/dev-tcltk/expect/files/expect-5.45.4-examples.patch
+++ b/dev-tcltk/expect/files/expect-5.45.4-examples.patch
@@ -1,21 +1,23 @@
--- a/Makefile.in 2018-09-26 15:59:09.049279363 +0200
+++ b/Makefile.in 2018-09-26 16:00:00.514427553 +0200
-@@ -32,16 +32,12 @@
+@@ -32,15 +32,17 @@
# SCRIPTS is a target. If this is a problem, just comment out the
# SCRIPTS target itself.
-SCRIPTS = timed-run timed-read ftp-rfc autopasswd lpunlock weather \
-- passmass rftp kibitz rlogin-cwd xpstat tkpasswd dislocate xkibitz \
-- tknewsbiff unbuffer mkpasswd cryptdir decryptdir autoexpect \
-- multixterm
+SCRIPTS = unbuffer
++_SCRIPTS = timed-run timed-read ftp-rfc autopasswd lpunlock weather \
+ passmass rftp kibitz rlogin-cwd xpstat tkpasswd dislocate xkibitz \
+- tknewsbiff unbuffer mkpasswd cryptdir decryptdir autoexpect \
++ tknewsbiff mkpasswd cryptdir decryptdir autoexpect \
+ multixterm
# A couple of the scripts have man pages of their own.
# You can delete these too if you don't want'em.
-SCRIPTS_MANPAGES = kibitz dislocate xkibitz tknewsbiff unbuffer mkpasswd \
-- passmass cryptdir decryptdir autoexpect multixterm
+SCRIPTS_MANPAGES = unbuffer
++_SCRIPTS_MANPAGES = kibitz dislocate xkibitz tknewsbiff unbuffer mkpasswd \
+ passmass cryptdir decryptdir autoexpect multixterm
- # allow us to handle null list gracefully, "end_of_list" should not exist