summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ald/ald-0.1.7-r1.ebuild')
-rw-r--r--dev-util/ald/ald-0.1.7-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/ald/ald-0.1.7-r1.ebuild b/dev-util/ald/ald-0.1.7-r1.ebuild
new file mode 100644
index 000000000000..31b708e12d74
--- /dev/null
+++ b/dev-util/ald/ald-0.1.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit autotools
+
+DESCRIPTION="Assembly Language Debugger - a tool for debugging executable programs at the assembly level"
+HOMEPAGE="http://ald.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ald/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug ncurses"
+
+DEPEND="ncurses? ( sys-libs/ncurses )"
+RDEPEND="${DEPEND}"
+
+DOCS=( BUGS ChangeLog README TODO )
+
+src_prepare() {
+ # respect CFLAGS (bug #240268)
+ sed -i -e "/^CFLAGS/d" configure.ac || die 'sed on CFLAGS failed'
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable ncurses curses) \
+ $(use_enable debug assert)
+}