summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/bustle/files')
-rw-r--r--dev-util/bustle/files/0001-bustle-dbus-monitor-fix-linking-order-libs-go-after-.patch44
-rw-r--r--dev-util/bustle/files/bustle-0.2.3-ghc-7.4.patch89
-rw-r--r--dev-util/bustle/files/bustle-0.2.3-restrict-gtk2hs-deps-to-gtkplus2.patch40
-rw-r--r--dev-util/bustle/files/bustle-0.4.0-ghc-7.4.patch46
-rw-r--r--dev-util/bustle/files/bustle-0.4.0-restrict-gtk2hs-deps-to-gtkplus2.patch76
-rw-r--r--dev-util/bustle/files/bustle-0.4.2-restrict-gtk2hs-deps-to-gtkplus2.patch61
-rw-r--r--dev-util/bustle/files/bustle-0.4.7-gtk-0.13.patch172
7 files changed, 528 insertions, 0 deletions
diff --git a/dev-util/bustle/files/0001-bustle-dbus-monitor-fix-linking-order-libs-go-after-.patch b/dev-util/bustle/files/0001-bustle-dbus-monitor-fix-linking-order-libs-go-after-.patch
new file mode 100644
index 000000000000..206bcbc28cc4
--- /dev/null
+++ b/dev-util/bustle/files/0001-bustle-dbus-monitor-fix-linking-order-libs-go-after-.patch
@@ -0,0 +1,44 @@
+From b1d7a9b492a8fbe38f60585f6d5a25908e79c973 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <st@anti-virus.by>
+Date: Mon, 7 Feb 2011 15:58:56 +0200
+Subject: [PATCH] bustle-dbus-monitor: fix linking order (libs go after object/source files)
+
+Fixes the following failure:
+
+ cc -O2 -pipe -Wl,--hash-style=gnu -Wl,-O1 -Wl,--as-needed \
+ -g -O2 `pkg-config --cflags --libs dbus-1` \
+ -Wall -Wunused \
+ -o bustle-dbus-monitor bustle-dbus-monitor.c
+ bustle-0.2.3/temp/ccodU65H.o: In function `main':
+ bustle-0.2.3/work/bustle-0.2.3/bustle-dbus-monitor.c:347: undefined reference to `dbus_error_init'
+ bustle-0.2.3/work/bustle-0.2.3/bustle-dbus-monitor.c:348: undefined reference to `dbus_bus_get'
+ bustle-0.2.3/temp/ccodU65H.o: In function `get_well_known_names':
+ bustle-0.2.3/work/bustle-0.2.3/bustle-dbus-monitor.c:241: undefined reference to `dbus_message_new_method_call'
+ bustle-0.2.3/work/bustle-0.2.3/bustle-dbus-monitor.c:249: undefined reference to `dbus_error_init'
+ bustle-0.2.3/work/bustle-0.2.3/bustle-dbus-monitor.c:250: undefined reference to `dbus_connection_send_with_reply_and_block'
+ bustle-0.2.3/work/bustle-0.2.3/bustle-dbus-monitor.c:252: undefined reference to `dbus_error_is_set'
+
+Signed-off-by: Sergei Trofimovich <st@anti-virus.by>
+---
+ Makefile | 5 +++--
+ 1 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 707790e..3f50370 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,8 +1,9 @@
+ bustle-dbus-monitor: bustle-dbus-monitor.c
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) \
+- -g -O2 `pkg-config --cflags --libs dbus-1` \
++ -g -O2 \
+ -Wall -Wunused \
+- -o bustle-dbus-monitor bustle-dbus-monitor.c
++ -o bustle-dbus-monitor bustle-dbus-monitor.c \
++ `pkg-config --cflags --libs dbus-1`
+
+ clean:
+ rm -f bustle-dbus-monitor
+--
+1.7.3.4
+
diff --git a/dev-util/bustle/files/bustle-0.2.3-ghc-7.4.patch b/dev-util/bustle/files/bustle-0.2.3-ghc-7.4.patch
new file mode 100644
index 000000000000..3c4544e32b7e
--- /dev/null
+++ b/dev-util/bustle/files/bustle-0.2.3-ghc-7.4.patch
@@ -0,0 +1,89 @@
+Starting with ghc-7.4 base and haskell98 are incompatible:
+
+ Ambiguous module name `Prelude':
+ it was found in multiple packages: base haskell98-2.0.0.1
+
+Gentoo-bug: https://bugs.gentoo.org/428226
+Reported-by: Chris Reffett
+diff --git a/Bustle/Noninteractive.hs b/Bustle/Noninteractive.hs
+index 2aa1e05..4a4d9b0 100644
+--- a/Bustle/Noninteractive.hs
++++ b/Bustle/Noninteractive.hs
+@@ -3,7 +3,8 @@ where
+
+ import Prelude hiding (log)
+
+-import System
++import System.Environment (getArgs)
++import System.Exit (exitFailure)
+ import System.IO (hPutStrLn, stderr)
+
+ import Bustle.Parser (readLog)
+diff --git a/Bustle/Stats.hs b/Bustle/Stats.hs
+index da374a5..939cafd 100644
+--- a/Bustle/Stats.hs
++++ b/Bustle/Stats.hs
+@@ -36,7 +36,7 @@ frequencies = reverse
+ where alt Nothing = Just 1
+ alt (Just n) = Just (n + 1)
+
+-mean :: Fractional a => [a] -> a
++mean :: (Eq a, Fractional a) => [a] -> a
+ mean = acc 0 0
+ where acc 0 _ [] = error "mean of empty list"
+ acc n t [] = t / n
+diff --git a/bustle-dot.hs b/bustle-dot.hs
+index aa7c45e..77d6f18 100644
+--- a/bustle-dot.hs
++++ b/bustle-dot.hs
+@@ -3,7 +3,9 @@ import Prelude hiding (log)
+ import Control.Monad
+ import Data.List
+ import Data.Maybe
+-import System
++import System.IO
++import System.Environment
++import System.Exit
+
+ import Bustle.Parser (readLog)
+ import Bustle.Types
+diff --git a/bustle.cabal b/bustle.cabal
+index 7ad7412..0a49ca1 100644
+--- a/bustle.cabal
++++ b/bustle.cabal
+@@ -27,11 +27,11 @@ Executable bustle
+ if flag(PostCabalizedGtk2HS)
+ -- Since gtk2hs 0.11, pango is a separate package, and its module names
+ -- have changed.
+- Build-Depends: haskell98, mtl, base >= 4 && < 5, containers, parsec,
++ Build-Depends: mtl, base >= 4 && < 5, containers, parsec,
+ filepath, process,
+ gtk > 0.11, glade, pango, glib, cairo
+ else
+- Build-Depends: haskell98, mtl, base >= 4 && < 5, containers, parsec,
++ Build-Depends: mtl, base >= 4 && < 5, containers, parsec,
+ filepath, process,
+ gtk > 0.10 && < 0.11, glade, pango, glib, cairo
+
+@@ -39,18 +39,18 @@ Executable bustle-count
+ Main-is: bustle-count.hs
+ Other-modules: Bustle.Parser, Bustle.Stats, Bustle.Types,
+ Bustle.Noninteractive
+- Build-Depends: haskell98, base >= 4 && < 5, containers, parsec
++ Build-Depends: base >= 4 && < 5, containers, parsec
+ Ghc-options: -Wall -fno-warn-unused-imports -fno-warn-unused-do-bind
+
+ Executable bustle-time
+ Main-is: bustle-time.hs
+ Other-modules: Bustle.Parser, Bustle.Stats, Bustle.Types,
+ Bustle.Noninteractive
+- Build-Depends: haskell98, base >= 4 && < 5, containers, parsec
++ Build-Depends: base >= 4 && < 5, containers, parsec
+ Ghc-options: -Wall -fno-warn-unused-imports -fno-warn-unused-do-bind
+
+ Executable bustle-dot
+ Main-is: bustle-dot.hs
+ Other-modules: Bustle.Parser, Bustle.Types
+- Build-Depends: haskell98, base >= 4 && < 5, containers, parsec
++ Build-Depends: base >= 4 && < 5, containers, parsec
+ Ghc-options: -Wall -fno-warn-unused-imports -fno-warn-unused-do-bind
diff --git a/dev-util/bustle/files/bustle-0.2.3-restrict-gtk2hs-deps-to-gtkplus2.patch b/dev-util/bustle/files/bustle-0.2.3-restrict-gtk2hs-deps-to-gtkplus2.patch
new file mode 100644
index 000000000000..18091352ab5a
--- /dev/null
+++ b/dev-util/bustle/files/bustle-0.2.3-restrict-gtk2hs-deps-to-gtkplus2.patch
@@ -0,0 +1,40 @@
+--- bustle-0.2.3-orig/bustle.cabal 2013-04-03 15:15:36.278582601 +1100
++++ bustle-0.2.3/bustle.cabal 2013-04-03 15:21:14.334592030 +1100
+@@ -27,30 +27,30 @@
+ if flag(PostCabalizedGtk2HS)
+ -- Since gtk2hs 0.11, pango is a separate package, and its module names
+ -- have changed.
+- Build-Depends: mtl, base >= 4 && < 5, containers, parsec,
++ Build-Depends: haskell98, mtl, base >= 4 && < 5, containers, parsec,
+ filepath, process,
+- gtk > 0.11, glade, pango, glib, cairo
++ gtk > 0.11 && < 0.13, glade < 0.13, pango < 0.13, glib < 0.13, cairo < 0.13
+ else
+- Build-Depends: mtl, base >= 4 && < 5, containers, parsec,
++ Build-Depends: haskell98, mtl, base >= 4 && < 5, containers, parsec,
+ filepath, process,
+- gtk > 0.10 && < 0.11, glade, pango, glib, cairo
++ gtk > 0.10 && < 0.11, glade < 0.13, pango < 0.13, glib < 0.13, cairo < 0.13
+
+ Executable bustle-count
+ Main-is: bustle-count.hs
+ Other-modules: Bustle.Parser, Bustle.Stats, Bustle.Types,
+ Bustle.Noninteractive
+- Build-Depends: base >= 4 && < 5, containers, parsec
++ Build-Depends: haskell98, base >= 4 && < 5, containers, parsec
+ Ghc-options: -Wall -fno-warn-unused-imports -fno-warn-unused-do-bind
+
+ Executable bustle-time
+ Main-is: bustle-time.hs
+ Other-modules: Bustle.Parser, Bustle.Stats, Bustle.Types,
+ Bustle.Noninteractive
+- Build-Depends: base >= 4 && < 5, containers, parsec
++ Build-Depends: haskell98, base >= 4 && < 5, containers, parsec
+ Ghc-options: -Wall -fno-warn-unused-imports -fno-warn-unused-do-bind
+
+ Executable bustle-dot
+ Main-is: bustle-dot.hs
+ Other-modules: Bustle.Parser, Bustle.Types
+- Build-Depends: base >= 4 && < 5, containers, parsec
++ Build-Depends: haskell98, base >= 4 && < 5, containers, parsec
+ Ghc-options: -Wall -fno-warn-unused-imports -fno-warn-unused-do-bind
diff --git a/dev-util/bustle/files/bustle-0.4.0-ghc-7.4.patch b/dev-util/bustle/files/bustle-0.4.0-ghc-7.4.patch
new file mode 100644
index 000000000000..0262dd8c9ddc
--- /dev/null
+++ b/dev-util/bustle/files/bustle-0.4.0-ghc-7.4.patch
@@ -0,0 +1,46 @@
+diff --git a/Bustle/Noninteractive.hs b/Bustle/Noninteractive.hs
+index 56e5d74..48d9461 100644
+--- a/Bustle/Noninteractive.hs
++++ b/Bustle/Noninteractive.hs
+@@ -25,7 +25,7 @@ where
+
+ import Prelude hiding (log)
+
+-import System
++import System.Exit (exitFailure)
+ import System.IO (hPutStrLn, stderr)
+ import Data.Maybe (fromMaybe, mapMaybe)
+ import Data.List (nub)
+diff --git a/Bustle/Stats.hs b/Bustle/Stats.hs
+index 8a3e206..d822058 100644
+--- a/Bustle/Stats.hs
++++ b/Bustle/Stats.hs
+@@ -68,7 +68,7 @@ frequencies = reverse
+ where alt Nothing = Just 1
+ alt (Just n) = Just (n + 1)
+
+-mean :: Fractional a => [a] -> a
++mean :: (Eq a, Fractional a) => [a] -> a
+ mean = acc 0 0
+ where acc 0 _ [] = error "mean of empty list"
+ acc n t [] = t / n
+diff --git a/bustle.cabal b/bustle.cabal
+index 93b16bd..cd47efa 100644
+--- a/bustle.cabal
++++ b/bustle.cabal
+@@ -94,7 +94,6 @@ Executable bustle
+ , glade
+ , glib
+ , gtk > 0.11
+- , haskell98
+ , mtl
+ , pango
+ , parsec
+@@ -114,7 +113,6 @@ Executable bustle
+ , glade
+ , glib
+ , gtk > 0.10 && < 0.11
+- , haskell98
+ , mtl
+ , pango
+ , parsec
diff --git a/dev-util/bustle/files/bustle-0.4.0-restrict-gtk2hs-deps-to-gtkplus2.patch b/dev-util/bustle/files/bustle-0.4.0-restrict-gtk2hs-deps-to-gtkplus2.patch
new file mode 100644
index 000000000000..fb7a149722b4
--- /dev/null
+++ b/dev-util/bustle/files/bustle-0.4.0-restrict-gtk2hs-deps-to-gtkplus2.patch
@@ -0,0 +1,76 @@
+--- bustle-0.4.0-orig/bustle.cabal 2013-04-03 15:59:57.193656822 +1100
++++ bustle-0.4.0/bustle.cabal 2013-04-03 15:09:21.825572157 +1100
+@@ -86,16 +86,17 @@
+ Build-Depends: base >= 4 && < 5
+ , binary
+ , bytestring
+- , cairo
++ , cairo < 0.13
+ , containers
+ , dbus-core == 0.9.*
+ , directory
+ , filepath
+- , glade
+- , glib
+- , gtk > 0.11
++ , glade < 0.13
++ , glib < 0.13
++ , gtk > 0.11 && < 0.13
++ , haskell98
+ , mtl
+- , pango
++ , pango < 0.13
+ , parsec
+ , pcap
+ , process
+@@ -105,16 +106,17 @@
+ Build-Depends: base >= 4 && < 5
+ , binary
+ , bytestring
+- , cairo
++ , cairo < 0.13
+ , containers
+ , dbus-core == 0.9.*
+ , directory
+ , filepath
+- , glade
+- , glib
++ , glade < 0.13
++ , glib < 0.13
+ , gtk > 0.10 && < 0.11
++ , haskell98
+ , mtl
+- , pango
++ , pango < 0.13
+ , parsec
+ , pcap
+ , process
+@@ -133,8 +135,8 @@
+ C-sources: c-sources/pcap-monitor.c
+ pkgconfig-depends: glib-2.0
+ Build-Depends: base >= 4 && < 5
+- , gtk > 0.11
+- , glib
++ , gtk > 0.11 && < 0.13
++ , glib < 0.13
+
+ Executable dump-messages
+ if flag(InteractiveTests) && flag(PostCabalizedGtk2HS)
+@@ -177,14 +179,14 @@
+ main-is: Test/Renderer.hs
+ other-modules: Bustle.Renderer
+ Build-Depends: base
+- , cairo
++ , cairo < 0.13
+ , containers
+ , dbus-core
+ , directory
+ , filepath
+- , gtk
++ , gtk < 0.13
+ , mtl
+- , pango
++ , pango < 0.13
+ , test-framework
+ , test-framework-hunit
+ , HUnit
diff --git a/dev-util/bustle/files/bustle-0.4.2-restrict-gtk2hs-deps-to-gtkplus2.patch b/dev-util/bustle/files/bustle-0.4.2-restrict-gtk2hs-deps-to-gtkplus2.patch
new file mode 100644
index 000000000000..74ab26ff8fcd
--- /dev/null
+++ b/dev-util/bustle/files/bustle-0.4.2-restrict-gtk2hs-deps-to-gtkplus2.patch
@@ -0,0 +1,61 @@
+--- bustle-0.4.2-orig/bustle.cabal 2012-11-15 02:19:34.000000000 +1100
++++ bustle-0.4.2/bustle.cabal 2013-04-03 15:07:35.381569187 +1100
+@@ -82,15 +82,15 @@
+
+ Build-Depends: base >= 4 && < 5
+ , bytestring
+- , cairo
++ , cairo < 0.13
+ , containers
+ , dbus >= 0.10
+ , directory
+ , filepath
+- , glib
+- , gtk >= 0.12.3
++ , glib < 0.13
++ , gtk >= 0.12.3 && < 0.13
+ , mtl
+- , pango
++ , pango < 0.13
+ , parsec
+ , pcap
+ , process
+@@ -111,15 +111,15 @@
+ pkgconfig-depends: glib-2.0
+ Build-Depends: base >= 4 && < 5
+ , bytestring
+- , cairo
++ , cairo < 0.13
+ , containers
+ , dbus
+ , directory
+ , filepath
+- , gtk > 0.12
+- , glib
++ , gtk > 0.12 && < 0.13
++ , glib < 0.13
+ , mtl
+- , pango
++ , pango < 0.13
+ , parsec
+ , pcap
+ , text
+@@ -163,15 +163,15 @@
+ main-is: Test/Renderer.hs
+ other-modules: Bustle.Renderer
+ Build-Depends: base
+- , cairo
++ , cairo < 0.13
+ , containers
+ , dbus >= 0.10
+ , directory
+ , filepath
+- , gtk
++ , gtk < 0.13
+ , mtl
+ , text
+- , pango
++ , pango < 0.13
+ , test-framework
+ , test-framework-hunit
+ , HUnit
diff --git a/dev-util/bustle/files/bustle-0.4.7-gtk-0.13.patch b/dev-util/bustle/files/bustle-0.4.7-gtk-0.13.patch
new file mode 100644
index 000000000000..f2691521c4bd
--- /dev/null
+++ b/dev-util/bustle/files/bustle-0.4.7-gtk-0.13.patch
@@ -0,0 +1,172 @@
+diff --git a/Bustle/Diagram.hs b/Bustle/Diagram.hs
+index d558beb..ef96d60 100644
+--- a/Bustle/Diagram.hs
++++ b/Bustle/Diagram.hs
+@@ -450,7 +450,7 @@ mkLayout :: (MonadIO m)
+ mkLayout s e a = liftIO $ do
+ ctx <- cairoCreateContext Nothing
+ layout <- layoutEmpty ctx
+- layoutSetMarkup layout (Markup.unMarkup s)
++ layoutSetMarkup layout (Markup.unMarkup s) :: IO String
+ layoutSetFontDescription layout (Just font)
+ layoutSetEllipsize layout e
+ layoutSetAlignment layout a
+diff --git a/Bustle/UI.hs b/Bustle/UI.hs
+index a78797e..9843b29 100644
+--- a/Bustle/UI.hs
++++ b/Bustle/UI.hs
+@@ -30,6 +30,7 @@ import Data.IORef
+ import qualified Data.Set as Set
+ import Data.List (intercalate)
+ import Data.Time
++import qualified Data.Text as T
+ import Data.Monoid (mempty)
+ import Text.Printf
+
+@@ -281,6 +282,7 @@ promptToSave wi = io $ do
+ case mdetails of
+ Just (RecordedLog tempFilePath) -> do
+ let tempFileName = takeFileName tempFilePath
++ title :: String
+ title = printf (__ "Save log '%s' before closing?") tempFileName
+ prompt <- messageDialogNew (Just (wiWindow wi))
+ [DialogModal]
+@@ -459,7 +461,7 @@ wiSetLogDetails :: WindowInfo
+ -> IO ()
+ wiSetLogDetails wi logDetails = do
+ writeIORef (wiLogDetails wi) (Just logDetails)
+- windowSetTitle (wiWindow wi) (printf (__ "%s - Bustle") (logWindowTitle logDetails))
++ windowSetTitle (wiWindow wi) (printf (__ "%s - Bustle") (logWindowTitle logDetails) :: String)
+
+ setPage :: MonadIO io
+ => WindowInfo
+@@ -525,7 +527,7 @@ loadPixbuf :: FilePath -> IO (Maybe Pixbuf)
+ loadPixbuf filename = do
+ iconName <- getDataFileName $ "data/" ++ filename
+ C.catch (fmap Just (pixbufNewFromFile iconName))
+- (\(GError _ _ msg) -> warn msg >> return Nothing)
++ (\(GError _ _ msg) -> warn (T.unpack msg) >> return Nothing)
+
+ openDialogue :: Window -> B ()
+ openDialogue window = embedIO $ \r -> do
+diff --git a/Bustle/UI/Canvas.hs b/Bustle/UI/Canvas.hs
+index 46c1582..5a28761 100644
+--- a/Bustle/UI/Canvas.hs
++++ b/Bustle/UI/Canvas.hs
+@@ -1,3 +1,4 @@
++{-# LANGUAGE OverloadedStrings #-}
+ {-
+ Bustle.UI.Canvas: displays diagrams
+ Copyright © 2008–2012 Collabora Ltd.
+@@ -58,7 +59,7 @@ canvasNew :: Eq a
+ -> (Maybe a -> IO ())
+ -> IO (Canvas a)
+ canvasNew builder showBounds selectionChangedCb = do
+- layout <- builderGetObject builder castToLayout "diagramLayout"
++ layout <- builderGetObject builder castToLayout ("diagramLayout" :: String)
+ idRef <- newIORef Nothing
+ shapesRef <- newIORef []
+ widthRef <- newIORef 0
+diff --git a/Bustle/UI/DetailsView.hs b/Bustle/UI/DetailsView.hs
+index 35e80d6..d1b9d96 100644
+--- a/Bustle/UI/DetailsView.hs
++++ b/Bustle/UI/DetailsView.hs
+@@ -55,7 +55,7 @@ addValue :: Table
+ -> Int
+ -> IO Label
+ addValue table row = do
+- label <- labelNew Nothing
++ label <- labelNew (Nothing :: Maybe String)
+ miscSetAlignment label 0 0
+ labelSetEllipsize label EllipsizeStart
+ labelSetSelectable label True
+@@ -77,7 +77,7 @@ detailsViewNew = do
+ , tableColumnSpacing := 6
+ ]
+
+- title <- labelNew Nothing
++ title <- labelNew (Nothing :: Maybe String)
+ miscSetAlignment title 0 0
+ tableAttach table title 0 2 0 1 [Fill] [Fill] 0 0
+
+diff --git a/Bustle/UI/FilterDialog.hs b/Bustle/UI/FilterDialog.hs
+index 9560507..152931e 100644
+--- a/Bustle/UI/FilterDialog.hs
++++ b/Bustle/UI/FilterDialog.hs
+@@ -99,7 +99,7 @@ runFilterDialog parent names currentlyHidden = do
+ nameStore <- makeStore names currentlyHidden
+ sw <- makeView nameStore
+
+- instructions <- labelNew Nothing
++ instructions <- labelNew (Nothing :: Maybe String)
+ widgetSetSizeRequest instructions 600 (-1)
+ labelSetMarkup instructions
+ (__ "Unticking a service hides its column in the diagram, \
+diff --git a/Bustle/UI/Recorder.hs b/Bustle/UI/Recorder.hs
+index 1e98a68..085eea2 100644
+--- a/Bustle/UI/Recorder.hs
++++ b/Bustle/UI/Recorder.hs
+@@ -27,6 +27,7 @@ import Control.Monad (when, liftM)
+ import Control.Concurrent.MVar
+ import qualified Data.Map as Map
+ import Data.Monoid
++import qualified Data.Text as T
+ import Control.Monad.State (runStateT)
+ import Text.Printf
+
+@@ -77,8 +78,7 @@ processBatch pendingRef n label incoming = do
+ -- message from the user's perspective.
+ i <- takeMVar n
+ let j = i + (length pending)
+- labelSetMarkup label $
+- printf (__ "Logged <b>%u</b> messages…") j
++ labelSetMarkup label $ (printf (__ "Logged <b>%u</b> messages…") j :: String)
+ putMVar n j
+
+ incoming rr'
+@@ -97,8 +97,8 @@ recorderRun filename mwindow incoming finished = C.handle newFailed $ do
+ maybe (return ()) (windowSetTransientFor dialog) mwindow
+ dialog `set` [ windowModal := True ]
+
+- label <- labelNew Nothing
+- labelSetMarkup label $ printf (__ "Logged <b>%u</b> messages…") (0 :: Int)
++ label <- labelNew (Nothing :: Maybe String)
++ labelSetMarkup label $ (printf (__ "Logged <b>%u</b> messages…") (0 :: Int) :: String)
+ loaderStateRef <- newMVar Map.empty
+ pendingRef <- newMVar []
+ let updateLabel µs body = do
+@@ -142,7 +142,7 @@ recorderRun filename mwindow incoming finished = C.handle newFailed $ do
+ widgetShowAll dialog
+ where
+ newFailed (GError _ _ message) = do
+- displayError mwindow message Nothing
++ displayError mwindow (T.unpack message) Nothing
+
+ recorderChooseFile :: FilePath
+ -> Maybe Window
+diff --git a/bustle.cabal b/bustle.cabal
+index 4ac107c..2d1f907 100644
+--- a/bustle.cabal
++++ b/bustle.cabal
+@@ -106,10 +106,10 @@ Executable bustle
+ , directory
+ , filepath
+ , glib
+- , gtk >= 0.12.4
++ , gtk >= 0.13
+ , hgettext >= 0.1.5
+ , mtl
+- , pango
++ , pango >= 0.13
+ , parsec
+ , pcap
+ , process
+@@ -136,7 +136,7 @@ Executable test-monitor
+ , dbus
+ , directory
+ , filepath
+- , gtk > 0.12
++ , gtk >= 0.13
+ , glib
+ , hgettext
+ , mtl