summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/codespell')
-rw-r--r--dev-util/codespell/Manifest1
-rw-r--r--dev-util/codespell/codespell-2.1.0.ebuild43
-rw-r--r--dev-util/codespell/metadata.xml21
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-util/codespell/Manifest b/dev-util/codespell/Manifest
new file mode 100644
index 000000000000..c0fb3621378b
--- /dev/null
+++ b/dev-util/codespell/Manifest
@@ -0,0 +1 @@
+DIST codespell-2.1.0.tar.gz 187490 BLAKE2B 6114aa3a7ad8cd37ab868a3f27f641501dd0cc5bfe80bef0aa5cad0a86f8e2bba6e1f1030d5ac6fb06f78f9e01e37359d0fc17d17eb54608060300f676d3d56c SHA512 16d9a4239ae18fad6a06825a2afae6adc903d50eb90b759cdc61b1e1d145458bbfb1385837c4465b0a9858da100be074c597343c4816ca0260bbf6710d9c84e8
diff --git a/dev-util/codespell/codespell-2.1.0.ebuild b/dev-util/codespell/codespell-2.1.0.ebuild
new file mode 100644
index 000000000000..f2f620ef41d1
--- /dev/null
+++ b/dev-util/codespell/codespell-2.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Check text files for common misspellings"
+HOMEPAGE="https://github.com/codespell-project/codespell"
+SRC_URI="https://github.com/codespell-project/codespell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# Code licensed under GPL-2
+# Dictionary licensed under CC-BY-SA-3.0
+LICENSE="GPL-2 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ sys-apps/help2man
+ test? ( dev-python/chardet[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # do not depend on pytest-cov
+ sed -e '/addopts/d' -i setup.cfg || die
+}
+
+python_compile_all() {
+ # generate included man page
+ emake ${PN}.1
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman ${PN}.1
+}
diff --git a/dev-util/codespell/metadata.xml b/dev-util/codespell/metadata.xml
new file mode 100644
index 000000000000..93753e364603
--- /dev/null
+++ b/dev-util/codespell/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person" proxied="yes">
+ <email>waebbl-gentoo@posteo.net</email>
+ <name>Bernd Waibel</name>
+</maintainer>
+<maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers</name>
+</maintainer>
+<longdescription lang="en">
+ A tool to fix common misspellings in text files. It's designed primarily
+ checking misspelled words in source code, but can be used with other
+ text files as well.
+</longdescription>
+<upstream>
+ <bugs-to>https://github.com/codespell-project/codespell/issues</bugs-to>
+ <remote-id type="github">codespell-project/codespell</remote-id>
+</upstream>
+</pkgmetadata>