summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/elfkickers/elfkickers-3.2.ebuild')
-rw-r--r--dev-util/elfkickers/elfkickers-3.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/elfkickers/elfkickers-3.2.ebuild b/dev-util/elfkickers/elfkickers-3.2.ebuild
new file mode 100644
index 000000000000..eabb5ab6febf
--- /dev/null
+++ b/dev-util/elfkickers/elfkickers-3.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_PN=${PN/elf/ELF}-${PV}
+
+DESCRIPTION="Collection of programs to manipulate ELF files: sstrip, rebind, elfls, elftoc"
+HOMEPAGE="http://www.muppetlabs.com/~breadbox/software/elfkickers.html"
+SRC_URI="http://www.muppetlabs.com/~breadbox/pub/software/${MY_PN}.tar.gz"
+S="${WORKDIR}"/${MY_PN}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="app-misc/pax-utils"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1-respect-CFLAGS-LDFLAGS.patch
+ "${FILESDIR}"/${PN}-3.1-create-destdir-path.patch
+ "${FILESDIR}"/add-freebsd-elf-defs.patch
+ "${FILESDIR}"/${PN}-3.1-AR.patch
+)
+
+src_prepare() {
+ default
+
+ tc-export AR CC
+
+ sed -i -e "s:^prefix = /usr/local:prefix = \${DESTDIR}/:" Makefile \
+ || die "sed failed"
+}