summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/fatrace/fatrace-0.9.ebuild')
-rw-r--r--dev-util/fatrace/fatrace-0.9.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/fatrace/fatrace-0.9.ebuild b/dev-util/fatrace/fatrace-0.9.ebuild
new file mode 100644
index 000000000000..afe7c165c9ef
--- /dev/null
+++ b/dev-util/fatrace/fatrace-0.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit linux-info python-r1 toolchain-funcs
+
+DESCRIPTION="report file access events from all running processes"
+HOMEPAGE="https://launchpad.net/fatrace"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="powertop"
+
+RDEPEND="powertop? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+REQUIRED_USE="powertop? ( ${PYTHON_REQUIRED_USE} )"
+
+CONFIG_CHECK="~FANOTIFY"
+
+src_prepare() {
+ tc-export CC
+}
+
+src_install() {
+ dosbin fatrace
+ use powertop && dosbin power-usage-report
+
+ doman fatrace.1
+ dodoc NEWS
+}