summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/maxcso/files/maxcso-1.13.0-ldflags.patch')
-rw-r--r--dev-util/maxcso/files/maxcso-1.13.0-ldflags.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/maxcso/files/maxcso-1.13.0-ldflags.patch b/dev-util/maxcso/files/maxcso-1.13.0-ldflags.patch
new file mode 100644
index 000000000000..ba6b92b0627a
--- /dev/null
+++ b/dev-util/maxcso/files/maxcso-1.13.0-ldflags.patch
@@ -0,0 +1,26 @@
+From 29458b4586c8bec1a025a71eab06146fc646ccc4 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Tue, 7 Dec 2021 07:17:28 -0800
+Subject: [PATCH] build: Support LDFLAGS
+
+Fixes the gentoo issue: https://bugs.gentoo.org/828416
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 4a93ec74..1cc7fc63 100644
+--- a/Makefile
++++ b/Makefile
+@@ -32,7 +32,7 @@ ZOPFLI_C_OBJ = $(ZOPFLI_C_SRC:.c=.o)
+
+ # TODO: Perhaps detect and use system libdeflate if available.
+ maxcso: $(SRC_CXX_OBJ) $(CLI_CXX_OBJ) $(ZOPFLI_C_OBJ) 7zip/7zip.a libdeflate/libdeflate.a
+- $(CXX) -o $@ $(SRC_CXXFLAGS) $(CXXFLAGS) $^ -luv -llz4 -lz
++ $(CXX) $(LDFLAGS) -o $@ $(SRC_CXXFLAGS) $(CXXFLAGS) $^ -luv -llz4 -lz
+
+ 7zip/7zip.a:
+ $(MAKE) -C 7zip 7zip.a
+--
+2.32.0
+