summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pkgconf/pkgconf-1.5.1.ebuild')
-rw-r--r--dev-util/pkgconf/pkgconf-1.5.1.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/dev-util/pkgconf/pkgconf-1.5.1.ebuild b/dev-util/pkgconf/pkgconf-1.5.1.ebuild
deleted file mode 100644
index 5b9170fe2f87..000000000000
--- a/dev-util/pkgconf/pkgconf-1.5.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
- inherit autotools git-r3
-else
- SRC_URI="https://distfiles.dereferenced.org/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-fi
-
-inherit multilib-minimal
-
-DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
-HOMEPAGE="https://github.com/pkgconf/pkgconf"
-
-LICENSE="BSD-1"
-SLOT="0/3"
-IUSE="+pkg-config test"
-
-# tests require 'kyua'
-RESTRICT="!test? ( test )"
-
-DEPEND="
- test? (
- dev-libs/atf
- dev-util/kyua
- )
-"
-RDEPEND="
- pkg-config? (
- !dev-util/pkgconfig
- !dev-util/pkg-config-lite
- !dev-util/pkgconfig-openbsd[pkg-config]
- )
-"
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/pkgconf
-)
-
-src_prepare() {
- default
-
- [[ ${PV} == "9999" ]] && eautoreconf
- if use pkg-config; then
- MULTILIB_CHOST_TOOLS+=(
- /usr/bin/pkg-config
- )
- fi
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} econf
-}
-
-multilib_src_test() {
- unset PKG_CONFIG_LIBDIR PKG_CONFIG_PATH
- default
-}
-
-multilib_src_install() {
- default
-
- if use pkg-config; then
- dosym pkgconf /usr/bin/pkg-config
- else
- rm "${ED%/}"/usr/share/aclocal/pkg.m4 || die
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
- find "${ED}" -name '*.la' -delete || die
-}