summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/re2c/re2c-1.0.3.ebuild')
-rw-r--r--dev-util/re2c/re2c-1.0.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/re2c/re2c-1.0.3.ebuild b/dev-util/re2c/re2c-1.0.3.ebuild
new file mode 100644
index 000000000000..bce28d1d0814
--- /dev/null
+++ b/dev-util/re2c/re2c-1.0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="tool for generating C-based recognizers from regular expressions"
+HOMEPAGE="http://re2c.org/"
+SRC_URI="https://github.com/skvadrik/re2c/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+
+src_prepare() {
+ default
+ export ac_cv_path_BISON="no"
+}
+
+src_install() {
+ default
+
+ docompress -x /usr/share/doc/${PF}/{examples,paper}
+ dodoc -r README CHANGELOG examples
+ docinto paper
+ dodoc doc/loplas.ps doc/tdfa/tdfa.pdf
+}