summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/trinity/trinity-1.5.ebuild')
-rw-r--r--dev-util/trinity/trinity-1.5.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/trinity/trinity-1.5.ebuild b/dev-util/trinity/trinity-1.5.ebuild
new file mode 100644
index 000000000000..baab1988db2d
--- /dev/null
+++ b/dev-util/trinity/trinity-1.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="A Linux system call fuzz tester"
+HOMEPAGE="http://codemonkey.org.uk/projects/trinity/"
+SRC_URI="http://codemonkey.org.uk/projects/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="
+ app-arch/xz-utils
+ sys-kernel/linux-headers
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flags.patch
+ tc-export CC
+}
+
+src_configure() {
+ ./configure.sh || die
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc Documentation/* README
+
+ if use examples ; then
+ exeinto /usr/share/doc/${PF}/scripts
+ doexe scripts/*
+ docompress -x /usr/share/doc/${PF}/scripts
+ fi
+}