summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/unifdef/unifdef-2.10.ebuild')
-rw-r--r--dev-util/unifdef/unifdef-2.10.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-util/unifdef/unifdef-2.10.ebuild b/dev-util/unifdef/unifdef-2.10.ebuild
new file mode 100644
index 000000000000..5d3b0e50eb94
--- /dev/null
+++ b/dev-util/unifdef/unifdef-2.10.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="remove #ifdef'ed lines from a file while otherwise leaving the file alone"
+HOMEPAGE="http://dotat.at/prog/unifdef/"
+SRC_URI="http://dotat.at/prog/unifdef/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 -sparc-fbsd -x86-fbsd ~amd64-linux ~x86-linux"
+
+DOCS=( README )
+
+src_prepare() {
+ sed -i '/^prefix/s:=.*:=/usr:' Makefile || die
+ tc-export CC
+}