summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/vulkan-tools/vulkan-tools-0_p20180526.ebuild')
-rw-r--r--dev-util/vulkan-tools/vulkan-tools-0_p20180526.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-util/vulkan-tools/vulkan-tools-0_p20180526.ebuild b/dev-util/vulkan-tools/vulkan-tools-0_p20180526.ebuild
deleted file mode 100644
index 143583c65a59..000000000000
--- a/dev-util/vulkan-tools/vulkan-tools-0_p20180526.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{4,5,6} )
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-Tools.git"
- EGIT_SUBMODULES=()
- inherit git-r3
-else
- EGIT_COMMIT="5e1623ca6860f3e393b1dabbdd19ba216871fa61"
- KEYWORDS="~amd64"
- SRC_URI="https://github.com/KhronosGroup/Vulkan-Tools/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/Vulkan-Tools-${EGIT_COMMIT}"
-fi
-
-inherit python-any-r1 cmake-multilib
-
-DESCRIPTION="Official Vulkan Tools and Utilities for Windows, Linux, Android, and MacOS"
-HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Tools"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="X wayland"
-
-# Old packaging will cause file collisions
-RDEPEND="!<=media-libs/vulkan-loader-1.1.70.0-r999"
-DEPEND="${PYTHON_DEPS}
- dev-util/glslang:=[${MULTILIB_USEDEP}]
- dev-util/vulkan-headers
- media-libs/vulkan-loader:=[${MULTILIB_USEDEP}]
- wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
- X? (
- x11-libs/libX11:=[${MULTILIB_USEDEP}]
- x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
- )"
-
-PATCHES=( "${FILESDIR}/${PN}-Use-usr-for-vulkan-headers.patch" )
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DCMAKE_SKIP_RPATH=True
- -DBUILD_WSI_MIR_SUPPORT=False
- -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
- -DBUILD_WSI_XCB_SUPPORT=$(usex X)
- -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
- -DGLSLANG_INSTALL_DIR="/usr"
- )
- cmake-utils_src_configure
-}