summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/w32api/w32api-3.17.2.ebuild')
-rw-r--r--dev-util/w32api/w32api-3.17.2.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/w32api/w32api-3.17.2.ebuild b/dev-util/w32api/w32api-3.17.2.ebuild
new file mode 100644
index 000000000000..2b8a78f1c5bc
--- /dev/null
+++ b/dev-util/w32api/w32api-3.17.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
+ fi
+fi
+
+inherit eutils flag-o-matic
+
+MY_P="${P:0:${#P}-2}-${PV:0-1}-mingw32"
+DESCRIPTION="Free Win32 runtime and import library definitions"
+HOMEPAGE="http://www.mingw.org/"
+# http://sourceforge.net/projects/mingw/files/MinGW/Base/w32api/
+SRC_URI="mirror://sourceforge/mingw/${MY_P}-src.tar.lzma"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE="crosscompile_opts_headers-only"
+RESTRICT="strip"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+just_headers() {
+ use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
+}
+
+pkg_setup() {
+ if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
+ die "Invalid configuration; do not emerge this directly"
+ fi
+}
+
+src_compile() {
+ just_headers && return 0
+
+ CHOST=${CTARGET} strip-unsupported-flags
+ econf \
+ --host=${CTARGET} \
+ --prefix=/usr/${CTARGET}/usr
+ emake || die
+}
+
+src_install() {
+ if just_headers ; then
+ insinto /usr/${CTARGET}/usr/include
+ doins -r include/* || die
+ else
+ emake install DESTDIR="${D}" || die
+ env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ dodoc CONTRIBUTIONS ChangeLog README.w32api TODO
+
+ # Make sure diff cross-compilers don't collide #414075
+ mv "${D}"/usr/share/doc/{${PF},${CTARGET}-${PF}} || die
+ fi
+}