summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-bzr-ng/git-bzr-ng-0_pre20120822-r2.ebuild')
-rw-r--r--dev-vcs/git-bzr-ng/git-bzr-ng-0_pre20120822-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-vcs/git-bzr-ng/git-bzr-ng-0_pre20120822-r2.ebuild b/dev-vcs/git-bzr-ng/git-bzr-ng-0_pre20120822-r2.ebuild
new file mode 100644
index 000000000000..129f43403ce3
--- /dev/null
+++ b/dev-vcs/git-bzr-ng/git-bzr-ng-0_pre20120822-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Git subcommand providing a bidirectional bridge to Bazaar repositories"
+HOMEPAGE="https://github.com/termie/git-bzr-ng"
+SRC_URI="https://dev.gentoo.org/~tetromino/distfiles/${PN}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=dev-vcs/bzr-2.2
+ dev-vcs/git
+ >=dev-vcs/bzr-fastimport-0.10
+ ${PYTHON_DEPS}"
+DEPEND="app-arch/xz-utils"
+
+src_prepare() {
+ default
+ python_fix_shebang git-bzr
+}
+
+src_install() {
+ exeinto /usr/libexec/git-core
+ doexe git-bzr
+ dodoc README.rst
+}