summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git/git-9999-r2.ebuild')
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index f725b2c09472..269086404b39 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -42,13 +42,13 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
+ gnome-keyring? ( app-crypt/libsecret )
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
- libsecret? ( app-crypt/libsecret )
sys-libs/zlib
pcre? ( dev-libs/libpcre )
perl? ( dev-lang/perl:=[-build(-)] )
@@ -358,7 +358,7 @@ src_compile() {
cd "${S}"
fi
- if use libsecret ; then
+ if use gnome-keyring ; then
cd "${S}"/contrib/credential/libsecret
git_emake || die "emake git-credential-libsecret failed"
fi
@@ -453,7 +453,7 @@ src_install() {
doexe contrib/contacts/git-contacts
dodoc contrib/contacts/git-contacts.txt
- if use libsecret ; then
+ if use gnome-keyring ; then
cd "${S}"/contrib/credential/libsecret
dobin git-credential-libsecret
fi