summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/subversion/subversion-1.13.0-r1.ebuild')
-rw-r--r--dev-vcs/subversion/subversion-1.13.0-r1.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-vcs/subversion/subversion-1.13.0-r1.ebuild b/dev-vcs/subversion/subversion-1.13.0-r1.ebuild
index 9534bafbacb7..3cf9f17eab26 100644
--- a/dev-vcs/subversion/subversion-1.13.0-r1.ebuild
+++ b/dev-vcs/subversion/subversion-1.13.0-r1.ebuild
@@ -154,6 +154,9 @@ pkg_setup() {
}
src_prepare() {
+ # https://bugs.gentoo.org/721300
+ rm "${WORKDIR}"/patches/subversion-1.10.0_rc1-utf8proc_include.patch || die
+
eapply "${WORKDIR}/patches"
eapply_user
@@ -260,6 +263,10 @@ src_configure() {
export ac_cv_python_compile="$(tc-getCC)"
fi
+ # Remove when >=dev-libs/libutf8proc-2.5.0 is stable
+ # https://bugs.gentoo.org/721300
+ append-cppflags -I"${EPREFIX}"/usr/include/libutf8proc
+
# allow overriding Python include directory
ac_cv_path_RUBY=$(usex ruby "${EPREFIX}/usr/bin/ruby${RB_VER}" "none") \
ac_cv_path_RDOC=$(usex ruby "${EPREFIX}/usr/bin/rdoc${RB_VER}" "none") \