summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/git-2.13.6.ebuild8
-rw-r--r--dev-vcs/git/git-2.14.3.ebuild7
-rw-r--r--dev-vcs/git/git-2.15.1.ebuild5
-rw-r--r--dev-vcs/git/git-2.16.0_rc2.ebuild5
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild5
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild5
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild5
-rw-r--r--dev-vcs/git/git-9999.ebuild5
8 files changed, 11 insertions, 34 deletions
diff --git a/dev-vcs/git/git-2.13.6.ebuild b/dev-vcs/git/git-2.13.6.ebuild
index 81e7734629c8..3f4dab26bde8 100644
--- a/dev-vcs/git/git-2.13.6.ebuild
+++ b/dev-vcs/git/git-2.13.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -280,7 +280,6 @@ src_prepare() {
}
git_emake() {
- # bug #326625: PERL_PATH, PERL_MM_OPT
# bug #320647: PYTHON_PATH
PYTHON_PATH=""
use python && PYTHON_PATH="${PYTHON}"
@@ -294,13 +293,12 @@ git_emake() {
htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
sysconfdir="${EPREFIX}"/etc \
PYTHON_PATH="${PYTHON_PATH}" \
+ PERL_PATH="${EPREFIX}/usr/bin/perl" \
PERL_MM_OPT="" \
GIT_TEST_OPTS="--no-color" \
V=1 \
"$@"
- # This is the fix for bug #326625, but it also causes breakage, see bug
- # #352693.
- # PERL_PATH="${EPREFIX}/usr/bin/env perl" \
+
}
src_configure() {
diff --git a/dev-vcs/git/git-2.14.3.ebuild b/dev-vcs/git/git-2.14.3.ebuild
index d079a65a75eb..fde79e887f8a 100644
--- a/dev-vcs/git/git-2.14.3.ebuild
+++ b/dev-vcs/git/git-2.14.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -299,7 +299,6 @@ src_prepare() {
}
git_emake() {
- # bug #326625: PERL_PATH, PERL_MM_OPT
# bug #320647: PYTHON_PATH
PYTHON_PATH=""
use python && PYTHON_PATH="${PYTHON}"
@@ -313,13 +312,11 @@ git_emake() {
htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
sysconfdir="${EPREFIX}"/etc \
PYTHON_PATH="${PYTHON_PATH}" \
+ PERL_PATH="${EPREFIX}/usr/bin/perl" \
PERL_MM_OPT="" \
GIT_TEST_OPTS="--no-color" \
V=1 \
"$@"
- # This is the fix for bug #326625, but it also causes breakage, see bug
- # #352693.
- # PERL_PATH="${EPREFIX}/usr/bin/env perl" \
}
src_configure() {
diff --git a/dev-vcs/git/git-2.15.1.ebuild b/dev-vcs/git/git-2.15.1.ebuild
index 3f45eb3ef445..d3e89d0092f7 100644
--- a/dev-vcs/git/git-2.15.1.ebuild
+++ b/dev-vcs/git/git-2.15.1.ebuild
@@ -299,7 +299,6 @@ src_prepare() {
}
git_emake() {
- # bug #326625: PERL_PATH, PERL_MM_OPT
# bug #320647: PYTHON_PATH
PYTHON_PATH=""
use python && PYTHON_PATH="${PYTHON}"
@@ -313,13 +312,11 @@ git_emake() {
htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
sysconfdir="${EPREFIX}"/etc \
PYTHON_PATH="${PYTHON_PATH}" \
+ PERL_PATH="${EPREFIX}/usr/bin/perl" \
PERL_MM_OPT="" \
GIT_TEST_OPTS="--no-color" \
V=1 \
"$@"
- # This is the fix for bug #326625, but it also causes breakage, see bug
- # #352693.
- # PERL_PATH="${EPREFIX}/usr/bin/env perl" \
}
src_configure() {
diff --git a/dev-vcs/git/git-2.16.0_rc2.ebuild b/dev-vcs/git/git-2.16.0_rc2.ebuild
index 3f45eb3ef445..d3e89d0092f7 100644
--- a/dev-vcs/git/git-2.16.0_rc2.ebuild
+++ b/dev-vcs/git/git-2.16.0_rc2.ebuild
@@ -299,7 +299,6 @@ src_prepare() {
}
git_emake() {
- # bug #326625: PERL_PATH, PERL_MM_OPT
# bug #320647: PYTHON_PATH
PYTHON_PATH=""
use python && PYTHON_PATH="${PYTHON}"
@@ -313,13 +312,11 @@ git_emake() {
htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
sysconfdir="${EPREFIX}"/etc \
PYTHON_PATH="${PYTHON_PATH}" \
+ PERL_PATH="${EPREFIX}/usr/bin/perl" \
PERL_MM_OPT="" \
GIT_TEST_OPTS="--no-color" \
V=1 \
"$@"
- # This is the fix for bug #326625, but it also causes breakage, see bug
- # #352693.
- # PERL_PATH="${EPREFIX}/usr/bin/env perl" \
}
src_configure() {
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index 3f45eb3ef445..d3e89d0092f7 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -299,7 +299,6 @@ src_prepare() {
}
git_emake() {
- # bug #326625: PERL_PATH, PERL_MM_OPT
# bug #320647: PYTHON_PATH
PYTHON_PATH=""
use python && PYTHON_PATH="${PYTHON}"
@@ -313,13 +312,11 @@ git_emake() {
htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
sysconfdir="${EPREFIX}"/etc \
PYTHON_PATH="${PYTHON_PATH}" \
+ PERL_PATH="${EPREFIX}/usr/bin/perl" \
PERL_MM_OPT="" \
GIT_TEST_OPTS="--no-color" \
V=1 \
"$@"
- # This is the fix for bug #326625, but it also causes breakage, see bug
- # #352693.
- # PERL_PATH="${EPREFIX}/usr/bin/env perl" \
}
src_configure() {
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 3f45eb3ef445..d3e89d0092f7 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -299,7 +299,6 @@ src_prepare() {
}
git_emake() {
- # bug #326625: PERL_PATH, PERL_MM_OPT
# bug #320647: PYTHON_PATH
PYTHON_PATH=""
use python && PYTHON_PATH="${PYTHON}"
@@ -313,13 +312,11 @@ git_emake() {
htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
sysconfdir="${EPREFIX}"/etc \
PYTHON_PATH="${PYTHON_PATH}" \
+ PERL_PATH="${EPREFIX}/usr/bin/perl" \
PERL_MM_OPT="" \
GIT_TEST_OPTS="--no-color" \
V=1 \
"$@"
- # This is the fix for bug #326625, but it also causes breakage, see bug
- # #352693.
- # PERL_PATH="${EPREFIX}/usr/bin/env perl" \
}
src_configure() {
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 3f45eb3ef445..d3e89d0092f7 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -299,7 +299,6 @@ src_prepare() {
}
git_emake() {
- # bug #326625: PERL_PATH, PERL_MM_OPT
# bug #320647: PYTHON_PATH
PYTHON_PATH=""
use python && PYTHON_PATH="${PYTHON}"
@@ -313,13 +312,11 @@ git_emake() {
htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
sysconfdir="${EPREFIX}"/etc \
PYTHON_PATH="${PYTHON_PATH}" \
+ PERL_PATH="${EPREFIX}/usr/bin/perl" \
PERL_MM_OPT="" \
GIT_TEST_OPTS="--no-color" \
V=1 \
"$@"
- # This is the fix for bug #326625, but it also causes breakage, see bug
- # #352693.
- # PERL_PATH="${EPREFIX}/usr/bin/env perl" \
}
src_configure() {
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 3f45eb3ef445..d3e89d0092f7 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -299,7 +299,6 @@ src_prepare() {
}
git_emake() {
- # bug #326625: PERL_PATH, PERL_MM_OPT
# bug #320647: PYTHON_PATH
PYTHON_PATH=""
use python && PYTHON_PATH="${PYTHON}"
@@ -313,13 +312,11 @@ git_emake() {
htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
sysconfdir="${EPREFIX}"/etc \
PYTHON_PATH="${PYTHON_PATH}" \
+ PERL_PATH="${EPREFIX}/usr/bin/perl" \
PERL_MM_OPT="" \
GIT_TEST_OPTS="--no-color" \
V=1 \
"$@"
- # This is the fix for bug #326625, but it also causes breakage, see bug
- # #352693.
- # PERL_PATH="${EPREFIX}/usr/bin/env perl" \
}
src_configure() {