summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/fossil/Manifest1
-rw-r--r--dev-vcs/fossil/fossil-2.11.1.ebuild72
-rw-r--r--dev-vcs/fossil/metadata.xml3
3 files changed, 0 insertions, 76 deletions
diff --git a/dev-vcs/fossil/Manifest b/dev-vcs/fossil/Manifest
index bafd954b09db..90af46f42afe 100644
--- a/dev-vcs/fossil/Manifest
+++ b/dev-vcs/fossil/Manifest
@@ -1,2 +1 @@
-DIST fossil-src-2.11.1.tar.gz 5850806 BLAKE2B 640807055100888d6bfea13539efb02190f07db5edcec58025952e464d50d4bd13992e5e8f5e515b01f52eaa3409d7a536bd4b48aecb5fdcf6214e47dc4963ed SHA512 055306c0d5c2f9b536ace6385ed79b5ced56d77dfc8e08b38f51075e97dfebfffca10aa7e17d2b22b9945c71b12eb131d49f3651e2890820dc9cb04719cd0265
DIST fossil-src-2.12.1.tar.gz 6011181 BLAKE2B f9437c4fb20314706bbbec70efbb6a53e2ac7760986baf88ea72505f03877a5d1069d0d2828aa2bfefac96c1358e4c8f824405d61fd24d490442fa8b768711e9 SHA512 08b7fef5a3071e968dedbc645aebf2e873ecf80049b5986d38f851a407b2b8b0c854cfcdfa5ec80eac5bc1b158c5fac3bb4b263d1adb8be470529e67dc6e8cee
diff --git a/dev-vcs/fossil/fossil-2.11.1.ebuild b/dev-vcs/fossil/fossil-2.11.1.ebuild
deleted file mode 100644
index dc00229d55ae..000000000000
--- a/dev-vcs/fossil/fossil-2.11.1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Simple, high-reliability, source control management, and more"
-HOMEPAGE="https://www.fossil-scm.org/"
-SRC_URI="https://fossil-scm.org/home/uv/fossil-src-${PV}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 x86"
-IUSE="debug fusefs json -legacy-mv-rm -miniz system-sqlite +ssl static
- tcl tcl-stubs tcl-private-stubs th1-docs th1-hooks"
-
-REQUIRED_USE="ssl? ( !miniz )"
-
-RDEPEND="
- sys-libs/zlib
- || (
- sys-libs/readline:0
- dev-libs/libedit
- )
- system-sqlite? ( >=dev-db/sqlite-3.28.0:3 )
- ssl? ( dev-libs/openssl:0 )
- tcl? ( dev-lang/tcl:0= )
-"
-
-# Either tcl or jimtcl need to be present to build Fossil (Bug #675778)
-DEPEND="${RDEPEND}
- !tcl? (
- || (
- dev-lang/tcl:*
- dev-lang/jimtcl:*
- )
- )
-"
-
-# Tests can't be run from the build directory
-RESTRICT="test"
-
-# fossil-2.10-check-lib64-for-tcl.patch: Bug 690828
-PATCHES=( "${FILESDIR}"/fossil-2.10-check-lib64-for-tcl.patch )
-
-src_configure() {
- # this is not an autotools situation so don't make it seem like one
- # --with-tcl: works
- # --without-tcl: dies
- local myconf="--with-openssl=$(usex ssl auto none)"
- use debug && myconf+=' --fossil-debug'
- use json && myconf+=' --json'
- use system-sqlite && myconf+=' --disable-internal-sqlite'
- use static && myconf+=' --static'
- use tcl && myconf+=' --with-tcl=1'
- use fusefs || myconf+=' --disable-fusefs'
-
- local u useflags
- useflags=( legacy-mv-rm miniz tcl-stubs tcl-private-stubs
- th1-docs th1-hooks )
- for u in ${useflags[@]} ; do
- use ${u} && myconf+=" --with-${u}"
- done
-
- tc-export CC CXX
- CC_FOR_BUILD=${CC} ./configure ${myconf} || die
-}
-
-src_install() {
- dobin fossil
-}
diff --git a/dev-vcs/fossil/metadata.xml b/dev-vcs/fossil/metadata.xml
index 5f61527e696f..b96ecf35bd4d 100644
--- a/dev-vcs/fossil/metadata.xml
+++ b/dev-vcs/fossil/metadata.xml
@@ -12,9 +12,6 @@
<use>
<flag name="fusefs">Enable the Fuse Filesystem</flag>
<flag name="json">Enable the JSON API of Fossil's wiki</flag>
- <flag name="legacy-mv-rm">
- Enable legacy behavior for mv/rm (skip checkout files).
- </flag>
<flag name="miniz">
Use the bundled miniz for compression instead of
zlib. Incompatible with ssl.