summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/polymc/polymc-9999.ebuild')
-rw-r--r--games-action/polymc/polymc-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/games-action/polymc/polymc-9999.ebuild b/games-action/polymc/polymc-9999.ebuild
index 96537440ecbc..cc17908560c9 100644
--- a/games-action/polymc/polymc-9999.ebuild
+++ b/games-action/polymc/polymc-9999.ebuild
@@ -39,11 +39,13 @@ LICENSE="Apache-2.0 Boost-1.0 BSD BSD-2 GPL-2+ GPL-3 LGPL-3 OFL-1.1 MIT"
SLOT="0"
-IUSE="debug lto"
+IUSE="debug lto test"
REQUIRED_USE="
lto? ( !debug )
"
+RESTRICT="!test? ( test )"
+
MIN_QT="5.12.0"
QT_DEPS="
@@ -92,6 +94,7 @@ src_configure(){
-DLauncher_APP_BINARY_NAME="${PN}"
-DENABLE_LTO=$(usex lto)
+ -DBUILD_TESTING=$(usex test)
)
if use debug; then