summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/alienwave/files')
-rw-r--r--games-arcade/alienwave/files/alienwave-0.3.0-gentoo.patch4
-rw-r--r--games-arcade/alienwave/files/alienwave-0.4.0-gentoo.patch22
2 files changed, 24 insertions, 2 deletions
diff --git a/games-arcade/alienwave/files/alienwave-0.3.0-gentoo.patch b/games-arcade/alienwave/files/alienwave-0.3.0-gentoo.patch
index 1b71f1cf1838..87d436ca57db 100644
--- a/games-arcade/alienwave/files/alienwave-0.3.0-gentoo.patch
+++ b/games-arcade/alienwave/files/alienwave-0.3.0-gentoo.patch
@@ -1,5 +1,5 @@
---- Makefile.old 2009-01-30 16:04:16.000000000 +0100
-+++ Makefile 2009-01-30 16:07:04.000000000 +0100
+--- Makefile.old
++++ Makefile
@@ -1,9 +1,7 @@
# This file is part of Alienwave, a game by Alessandro Pira
diff --git a/games-arcade/alienwave/files/alienwave-0.4.0-gentoo.patch b/games-arcade/alienwave/files/alienwave-0.4.0-gentoo.patch
new file mode 100644
index 000000000000..bed5d38c0b8f
--- /dev/null
+++ b/games-arcade/alienwave/files/alienwave-0.4.0-gentoo.patch
@@ -0,0 +1,22 @@
+--- alienwave.orig/Makefile
++++ alienwave/Makefile
+@@ -1,9 +1,7 @@
+ # This file is part of Alienwave, a game by Alessandro Pira
+
+-CC = gcc
+ OBJS = main.o blit.o aliens.o xzarna.o fire.o shield.o levels.o util.o
+ # CFLAGS = -c -O2 -Wall -DDEBUG_LEV
+-CFLAGS = -c -O2 -Wall
+ LIB = -lncurses
+
+ # Uncomment this if you want random waves
+@@ -16,8 +14,7 @@
+
+
+ alienwave: $(OBJS)
+- $(CC) $(OBJS) $(LIB) -o alienwave
+- strip alienwave
++ $(CC) $(OBJS) $(LDFLAGS) $(LIB) -o alienwave
+
+ main.o: main.c
+